package/i2pd: link with libatomic when needed
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Fri, 15 Feb 2019 21:05:59 +0000 (22:05 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 24 Feb 2019 21:02:32 +0000 (22:02 +0100)
On some architectures, atomic binutils are provided by the libatomic
library from gcc. Linking with libatomic is therefore necessary,
otherwise the build fails with:

sparc-buildroot-linux-uclibc/sysroot/lib/libatomic.so.1: error adding symbols: DSO missing from command line

This is often for example the case on sparcv8 32 bit.

Fixes:
 - http://autobuild.buildroot.org/results/515160349b11f06a090f3e13992e30da9a402c17

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/i2pd/i2pd.mk

index a92d513159da95363dc40ed7e4459729864f1517..3ce5f97fb84f9b8b61fcfd494dd43ff1d16a1299 100644 (file)
@@ -21,6 +21,10 @@ I2PD_CONF_OPTS += -DWITH_GUI=OFF
 # build failure when cross-compiling.
 I2PD_CONF_OPTS += -DTHREADS_PTHREAD_ARG=OFF
 
+ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
+I2PD_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -latomic"
+endif
+
 ifeq ($(BR2_STATIC_LIBS),y)
 I2PD_CONF_OPTS += -DWITH_STATIC=ON
 else