libnl: minor package fixes
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Mon, 16 May 2011 14:18:26 +0000 (11:18 -0300)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 16 May 2011 20:54:37 +0000 (22:54 +0200)
* libnl fails to build with multiple jobs so keep make at -j1
* Multiple libraries are installed so update uninstall target for this

[Peter: remove libnl/libnl-*.* to catch subdir + any new libs in the future]
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/libnl/libnl.mk

index 8d3b9ade79f3fa0cbf5ad4d875ddfbd88c5dec79..6edb1f8e5f1501bff943db03f0e1c3063288e923 100644 (file)
@@ -9,9 +9,11 @@ LIBNL_SOURCE = libnl-$(LIBNL_VERSION).tar.gz
 LIBNL_SITE = http://www.infradead.org/~tgr/libnl/files/
 LIBNL_INSTALL_STAGING = YES
 LIBNL_DEPENDENCIES = host-bison
+LIBNL_MAKE = $(MAKE1)
 
 define LIBNL_UNINSTALL_TARGET_CMDS
-       rm -f $(TARGET_DIR)/usr/lib/libnl.so*
+       rm -r $(TARGET_DIR)/usr/lib/libnl.* $(TARGET_DIR)/usr/lib/libnl-*.*
+       rm -rf $(TARGET_DIR)/usr/lib/libnl
 endef
 
 $(eval $(call AUTOTARGETS,package,libnl))