uclibc: update uClibc-ng to version 1.0.13
authorWaldemar Brodkorb <wbx@openadk.org>
Sun, 13 Mar 2016 23:08:06 +0000 (00:08 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Mon, 14 Mar 2016 07:50:30 +0000 (08:50 +0100)
Remove patches included upstream.

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/uclibc/0001-include-netdb.h-Do-not-define-IDN-related-flags.patch [deleted file]
package/uclibc/0002-mips-fix-build-if-threads-are-disabled.patch [deleted file]
package/uclibc/uclibc.hash
package/uclibc/uclibc.mk

diff --git a/package/uclibc/0001-include-netdb.h-Do-not-define-IDN-related-flags.patch b/package/uclibc/0001-include-netdb.h-Do-not-define-IDN-related-flags.patch
deleted file mode 100644 (file)
index c1985ef..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From 5e9a78c8a839381add6faa61e196e6dad9143163 Mon Sep 17 00:00:00 2001
-From: Thomas Claveirole <thomas.claveirole@green-communications.fr>
-Date: Tue, 2 Feb 2016 12:13:09 +0100
-Subject: [PATCH] include/netdb.h: Do not define IDN-related flags.
-
-getaddrinfo() does not implement IDN encoding, and always fail when
-provided an IDN flag (e.g., AI_IDN) with EAI_BADFLAGS.  Some packages
-(such as the VLC media player) check for AI_IDN before they use it;
-providing an unimplemented AI_IDN in the libc makes these package
-fail.  As a result they make calls to getaddrinfo() with AI_IDN that
-always fail while they could have made successful calls without AI_IDN
-instead.
-
-Thus, do not define IDN flags: it is better not to compile rather than
-to compile a code that always fail.
-
-Signed-off-by: Thomas Claveirole <thomas.claveirole@green-communications.fr>
-Signed-off-by: Waldemar Brodkorb <wbx@uclibc-ng.org>
----
- include/netdb.h |   11 -----------
- 1 file changed, 11 deletions(-)
-
-diff --git a/include/netdb.h b/include/netdb.h
-index a636b5f..95abe95 100644
---- a/include/netdb.h
-+++ b/include/netdb.h
-@@ -627,16 +627,6 @@ struct addrinfo
- # define AI_ALL               0x0010  /* Return IPv4 mapped and IPv6 addresses.  */
- # define AI_ADDRCONFIG        0x0020  /* Use configuration of this host to choose
-                                  returned address type..  */
--# ifdef __USE_GNU
--#  define AI_IDN      0x0040  /* IDN encode input (assuming it is encoded
--                                 in the current locale's character set)
--                                 before looking it up. */
--#  define AI_CANONIDN 0x0080  /* Translate canonical name from IDN format. */
--#  define AI_IDN_ALLOW_UNASSIGNED 0x0100 /* Don't reject unassigned Unicode
--                                          code points.  */
--#  define AI_IDN_USE_STD3_ASCII_RULES 0x0200 /* Validate strings according to
--                                              STD3 rules.  */
--# endif
- # define AI_NUMERICSERV       0x0400  /* Don't use name resolution.  */
- /* Error values for `getaddrinfo' function.  */
-@@ -658,7 +648,6 @@ struct addrinfo
- #  define EAI_NOTCANCELED -102        /* Request not canceled.  */
- #  define EAI_ALLDONE   -103  /* All requests done.  */
- #  define EAI_INTR      -104  /* Interrupted by a signal.  */
--#  define EAI_IDN_ENCODE  -105        /* IDN encoding failed.  */
- # endif
- # ifdef __USE_MISC
--- 
-1.7.10.4
-
diff --git a/package/uclibc/0002-mips-fix-build-if-threads-are-disabled.patch b/package/uclibc/0002-mips-fix-build-if-threads-are-disabled.patch
deleted file mode 100644 (file)
index a74a5f9..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-From b499fe614ac5b492fc0fdc6e1fbbeeb904674159 Mon Sep 17 00:00:00 2001
-From: Waldemar Brodkorb <wbx@uclibc-ng.org>
-Date: Wed, 3 Feb 2016 21:57:04 +0100
-Subject: [PATCH] mips: fix build if threads are disabled
-
-Reported-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-Signed-off-by: Waldemar Brodkorb <wbx@uclibc-ng.org>
----
- libc/string/mips/memcpy.S |    4 ++--
- libc/string/mips/memset.S |    4 ++--
- 2 files changed, 4 insertions(+), 4 deletions(-)
-
-diff --git a/libc/string/mips/memcpy.S b/libc/string/mips/memcpy.S
-index 3afdb2c..59f9f0a 100644
---- a/libc/string/mips/memcpy.S
-+++ b/libc/string/mips/memcpy.S
-@@ -23,7 +23,7 @@
- # define PREFETCH_STORE_HINT PREFETCH_HINT_PREPAREFORSTORE
- #elif _LIBC
- # include <sysdep.h>
--# include <regdef.h>
-+# include <sys/regdef.h>
- # include <sys/asm.h>
- # define PREFETCH_LOAD_HINT PREFETCH_HINT_LOAD_STREAMED
- # define PREFETCH_STORE_HINT PREFETCH_HINT_PREPAREFORSTORE
-@@ -33,7 +33,7 @@
- # define PREFETCH_LOAD_HINT PREFETCH_HINT_LOAD_STREAMED
- # define PREFETCH_STORE_HINT PREFETCH_HINT_PREPAREFORSTORE
- #else
--# include <regdef.h>
-+# include <sys/regdef.h>
- # include <sys/asm.h>
- #endif
-diff --git a/libc/string/mips/memset.S b/libc/string/mips/memset.S
-index ef8ab0b..43034ce 100644
---- a/libc/string/mips/memset.S
-+++ b/libc/string/mips/memset.S
-@@ -21,7 +21,7 @@
- # define PREFETCH_STORE_HINT PREFETCH_HINT_PREPAREFORSTORE
- #elif _LIBC
- # include <sysdep.h>
--# include <regdef.h>
-+# include <sys/regdef.h>
- # include <sys/asm.h>
- # define PREFETCH_STORE_HINT PREFETCH_HINT_PREPAREFORSTORE
- #elif defined _COMPILING_NEWLIB
-@@ -29,7 +29,7 @@
- # include "machine/regdef.h"
- # define PREFETCH_STORE_HINT PREFETCH_HINT_PREPAREFORSTORE
- #else
--# include <regdef.h>
-+# include <sys/regdef.h>
- # include <sys/asm.h>
- #endif
--- 
-1.7.10.4
-
index 1290f920093680d81872e8548cdaf991cf8d9bc2..b700406e0af4e2ac3bf1d97ab84e8756a4a4a3aa 100644 (file)
@@ -1,2 +1,2 @@
 # From http://www.uclibc-ng.org/
-sha256  c238b300356b2638432e023076293f29935094108a2714ad1762b76015fae729        uClibc-ng-1.0.12.tar.xz
+sha256  7baae61e243da3ab85e219fead68406995be5eabf889001c0d41676546b19317        uClibc-ng-1.0.13.tar.xz
index 200de043e4a9ee198ec54b0d88011da746918052..88a4a8cf42b1bd4024ac84a58740f29d932db1e8 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-UCLIBC_VERSION = 1.0.12
+UCLIBC_VERSION = 1.0.13
 UCLIBC_SOURCE = uClibc-ng-$(UCLIBC_VERSION).tar.xz
 UCLIBC_SITE = http://downloads.uclibc-ng.org/releases/$(UCLIBC_VERSION)
 UCLIBC_LICENSE = LGPLv2.1+