directfb: bump version, unbreak png support
authorPeter Korsgaard <jacmet@sunsite.dk>
Wed, 6 Oct 2010 14:44:57 +0000 (16:44 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Wed, 6 Oct 2010 14:44:57 +0000 (16:44 +0200)
The recent libpng bump broke png support in directfb, as it relied
on the legacy 1.2 interface. Fix it by bumping the directfb version,
and at the same time ensure that configure finds our cross-libpng-config
rather than what the host version the user might have in the path.

Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
CHANGES
package/directfb/directfb.mk

diff --git a/CHANGES b/CHANGES
index c2ab972a29ff44d0e8dec9a0b295aef3d66fa1bd..c96bc4dbb67f9403d2bfb3aaca155247e3584597 100644 (file)
--- a/CHANGES
+++ b/CHANGES
@@ -25,9 +25,9 @@
 
        Updated/fixed packages: acpid, alsa-lib, argus, at, autoconf,
        automake, avahi, axel, beecrypt, berkeleydb, bind, bmon, boa,
-       bootutils, bridge-utils, bsdiff, busybox, cvs, dbus, dmraid,
-       docker, dosfstools, dropbear, e2fsprogs, expat, ezxml, fbset,
-       fconfig, ffmpeg, freetype, gadgetfs-test, gamin, gawk,
+       bootutils, bridge-utils, bsdiff, busybox, cvs, dbus, directfb,
+       dmraid, docker, dosfstools, dropbear, e2fsprogs, expat, ezxml,
+       fbset, fconfig, ffmpeg, freetype, gadgetfs-test, gamin, gawk,
        genext2fs, gperf, gst-plugins-ugly, gtk2-themes, gtkperf,
        gvfs, haserl, hdparm, hostapd, hwdata, ifplugd, imagemagick,
        iperf, ipsec-tools, iproute2, iptables, iw, jpeg, kexec,
index ccb0c5aa9a11dcd381335996514d07473cc473aa..05d36732b9f963f54366a1b388c03011eeb22d56 100644 (file)
@@ -4,7 +4,7 @@
 #
 #############################################################
 DIRECTFB_VERSION_MAJOR:=1.4
-DIRECTFB_VERSION:=1.4.3
+DIRECTFB_VERSION:=1.4.5
 DIRECTFB_SITE:=http://www.directfb.org/downloads/Core/DirectFB-$(DIRECTFB_VERSION_MAJOR)
 DIRECTFB_SOURCE:=DirectFB-$(DIRECTFB_VERSION).tar.gz
 DIRECTFB_AUTORECONF = NO
@@ -104,6 +104,7 @@ endif
 ifeq ($(BR2_PACKAGE_DIRECTFB_PNG),y)
 DIRECTFB_PNG:=--enable-png
 DIRECTFB_DEP+= libpng
+DIRECTFB_CONF_ENV += ac_cv_path_LIBPNG_CONFIG=$(STAGING_DIR)/usr/bin/libpng-config
 else
 DIRECTFB_PNG:=--disable-png
 endif