package/efl/libefl: add wayland dependency
authorRomain Naour <romain.naour@openwide.fr>
Tue, 15 Dec 2015 22:40:15 +0000 (23:40 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 17 Dec 2015 22:52:59 +0000 (23:52 +0100)
See:
https://www.enlightenment.org/about-wayland

Signed-off-by: Romain Naour <romain.naour@openwide.fr>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/efl/libefl/Config.in
package/efl/libefl/libefl.mk

index 6788bb3690891ccd8d0593e974ecb6bfd941430e..7d635d97369ec07de9f135d9bf2905fc2c59236e 100644 (file)
@@ -4,6 +4,7 @@ config BR2_PACKAGE_LIBEFL
        select BR2_PACKAGE_FREETYPE
        select BR2_PACKAGE_JPEG # Emile needs libjpeg
        select BR2_PACKAGE_LIBCURL # Ecore_con_url, runtime dependency
+       select BR2_PACKAGE_LIBXKBCOMMON if BR2_PACKAGE_WAYLAND
        select BR2_PACKAGE_UTIL_LINUX
        # libblkid is part of required tools, see EFL's README.
        select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
index 184604b22187c83ca0b70cbed29975e4fd3e15dc..e21d89cea90e5f48fe51ac511408fe2e4ac56fee 100644 (file)
@@ -35,7 +35,6 @@ LIBEFL_GETTEXTIZE = YES
 # --disable-image-loader-webp: disable webp support.
 # --disable-sdl: disable sdl2 support.
 # --disable-systemd: disable systemd support.
-# --disable-wayland: disable wayland support.
 # --enable-lua-old: disable Elua and remove luajit dependency.
 # --with-opengl=none: disable opengl support.
 # --with-x11=none: remove dependency on X.org.
@@ -48,7 +47,6 @@ LIBEFL_CONF_OPTS = \
        --disable-image-loader-webp \
        --disable-sdl \
        --disable-systemd \
-       --disable-wayland \
        --enable-lua-old \
        --with-opengl=none \
        --with-x11=none
@@ -140,6 +138,13 @@ else
 LIBEFL_CONF_OPTS += --with-crypto=none
 endif # BR2_PACKAGE_OPENSSL
 
+ifeq ($(BR2_PACKAGE_WAYLAND),y)
+LIBEFL_DEPENDENCIES += wayland libxkbcommon
+LIBEFL_CONF_OPTS += --enable-wayland
+else
+LIBEFL_CONF_OPTS += --disable-wayland
+endif
+
 # Loaders that need external dependencies needs to be --enable-XXX=yes
 # otherwise the default is '=static'.
 # All other loaders are statically built-in