- make sure we use the proper CC for building binutils.
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 10 Mar 2006 08:46:36 +0000 (08:46 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Fri, 10 Mar 2006 08:46:36 +0000 (08:46 -0000)
- add config option BR2_EXTRA_BINUTILS_CONFIG_OPTIONS for passing additional
  flags to binutils configure.

toolchain/binutils/Config.in
toolchain/binutils/binutils.mk

index 112ff077d0c3387dbb556757eb66ff1e0a7bca0a..68518f7d582e1e3931de7d496c5b8f1652308176 100644 (file)
@@ -61,3 +61,12 @@ config BR2_BINUTILS_VERSION
        default "2.16.91.0.4"     if BR2_BINUTILS_VERSION_2_16_91_0_4
        default "2.16.91.0.5"     if BR2_BINUTILS_VERSION_2_16_91_0_5
        default "2.16.91.0.6"     if BR2_BINUTILS_VERSION_2_16_91_0_6
+
+
+config BR2_EXTRA_BINUTILS_CONFIG_OPTIONS
+        string "Additional binutils options"
+        default ""
+        help
+            Any additional binutils options you may want to include..
+
+
index e6174d4227971db0fff14c57078c88da2e35f827..c5cdae0e99c01b1b92aaf451ad74124ee13d8236 100644 (file)
@@ -5,6 +5,8 @@
 #############################################################
 BINUTILS_VERSION:=$(strip $(subst ",, $(BR2_BINUTILS_VERSION)))
 
+EXTRA_BINUTILS_CONFIG_OPTIONS:=$(strip $(subst ",, $(BR2_EXTRA_BINUTILS_CONFIG_OPTIONS)))
+#"
 BINUTILS_SITE:=http://ftp.kernel.org/pub/linux/devel/binutils
 ifeq ($(BINUTILS_VERSION),2.16)
 BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/
@@ -49,6 +51,7 @@ $(BINUTILS_DIR)/.patched: $(BINUTILS_DIR)/.unpacked
 $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
        mkdir -p $(BINUTILS_DIR1)
        (cd $(BINUTILS_DIR1); \
+               CC="$(HOSTCC)" \
                $(BINUTILS_DIR)/configure \
                --prefix=$(STAGING_DIR) \
                --build=$(GNU_HOST_NAME) \
@@ -57,7 +60,8 @@ $(BINUTILS_DIR1)/.configured: $(BINUTILS_DIR)/.patched
                $(DISABLE_NLS) \
                $(MULTILIB) \
                --disable-werror \
-               $(SOFT_FLOAT_CONFIG_OPTION) );
+               $(SOFT_FLOAT_CONFIG_OPTION) \
+               $(EXTRA_BINUTILS_CONFIG_OPTIONS));
        touch $(BINUTILS_DIR1)/.configured
 
 $(BINUTILS_DIR1)/binutils/objdump: $(BINUTILS_DIR1)/.configured