libusb: bump to version 1.0.18
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Tue, 28 Jan 2014 20:11:35 +0000 (17:11 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Tue, 28 Jan 2014 20:59:45 +0000 (21:59 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libusb/Config.in
package/libusb/libusb-01-uclinux.patch [deleted file]
package/libusb/libusb.mk

index 2c2b8ce1732962611dff8b7488f57a8148bbe098..5238588aa8b947ed42965865f3cd299f5ef885db 100644 (file)
@@ -4,7 +4,7 @@ config BR2_PACKAGE_LIBUSB
        help
          Userspace library for accessing USB devices
 
-         http://libusb.sourceforge.net/
+         http://libusb.info/
 
 comment "libusb needs a toolchain w/ threads"
        depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/libusb/libusb-01-uclinux.patch b/package/libusb/libusb-01-uclinux.patch
deleted file mode 100644 (file)
index cbf48a7..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-*-uclinux* is valid in the tuple for linux, it's used for flat binaries
-for example.
-Patch both configure* for consistency and to avoid an unnecessary autoreconf.
-
-Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
-
-diff -Nura libusb-1.0.9.orig/configure libusb-1.0.9/configure
---- libusb-1.0.9.orig/configure        2013-09-03 10:13:52.212301259 -0300
-+++ libusb-1.0.9/configure     2013-09-03 10:19:08.443669386 -0300
-@@ -11093,7 +11093,7 @@
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking operating system" >&5
- $as_echo_n "checking operating system... " >&6; }
- case $host in
--*-linux*)
-+*-linux* | *-uclinux*)
-       { $as_echo "$as_me:${as_lineno-$LINENO}: result: Linux" >&5
- $as_echo "Linux" >&6; }
-       backend="linux"
-diff -Nura libusb-1.0.9.orig/configure.ac libusb-1.0.9/configure.ac
---- libusb-1.0.9.orig/configure.ac     2013-09-03 10:13:52.212301259 -0300
-+++ libusb-1.0.9/configure.ac  2013-09-03 10:19:00.573411346 -0300
-@@ -46,7 +46,7 @@
- AC_MSG_CHECKING([operating system])
- case $host in
--*-linux*)
-+*-linux* | *-uclinux*)
-       AC_MSG_RESULT([Linux])
-       backend="linux"
-       ;;
index 99f571cf40f325a57acad3480c79dc3c01e1a219..a595a12aed90270122f3d8b17036cfd74d6698eb 100644 (file)
@@ -5,7 +5,7 @@
 ################################################################################
 
 LIBUSB_VERSION_MAJOR = 1.0
-LIBUSB_VERSION = $(LIBUSB_VERSION_MAJOR).9
+LIBUSB_VERSION = $(LIBUSB_VERSION_MAJOR).18
 LIBUSB_SOURCE = libusb-$(LIBUSB_VERSION).tar.bz2
 LIBUSB_SITE = http://downloads.sourceforge.net/project/libusb/libusb-$(LIBUSB_VERSION_MAJOR)/libusb-$(LIBUSB_VERSION)
 LIBUSB_LICENSE = LGPLv2.1+
@@ -17,5 +17,11 @@ ifeq ($(BR2_avr32),y)
 LIBUSB_CONF_OPT += --disable-timerfd
 endif
 
+ifeq ($(BR2_ROOTFS_DEVICE_CREATION_DYNAMIC_UDEV),y)
+LIBUSB_DEPENDENCIES += udev
+else
+LIBUSB_CONF_OPT += --disable-udev
+endif
+
 $(eval $(autotools-package))
 $(eval $(host-autotools-package))