xenomai: Add choice for enabling/disabling Cobalt/Mercury core
authorPawel Sikora <sikor6@gmail.com>
Mon, 10 Apr 2017 17:26:02 +0000 (19:26 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 12 Apr 2017 20:52:00 +0000 (22:52 +0200)
Add an option choice for Cobalt or Mercury core
depending on option BR2_LINUX_KERNEL_EXT_XENOMAI.

Signed-off-by: Pawel Sikora <sikor6@gmail.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout at mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xenomai/Config.in
package/xenomai/xenomai.mk

index b548ee810a0e90b6a2e19dc77ceeddb07b557494..324f5025afaa11a14c9c22059548514e0eab22e7 100644 (file)
@@ -51,6 +51,33 @@ config BR2_PACKAGE_XENOMAI_VERSION
          BR2_LINUX_KERNEL_EXT_XENOMAI_ADEOS_PATCH, in the Linux
          Kernel -> Linux Kernel Extensions menu.
 
+choice
+       prompt "Xenomai core"
+       default BR2_PACKAGE_XENOMAI_MERCURY
+       help
+         Select the Xenomai core: dual kernel (Cobalt)
+         or native Linux Kernel (Mercury).
+
+config BR2_PACKAGE_XENOMAI_MERCURY
+       bool "Mercury"
+       depends on !BR2_LINUX_KERNEL_EXT_XENOMAI
+       help
+         Select Mercury core for the Xenomai userspace.
+         You want to use it if you have the native Linux Kernel.
+
+config BR2_PACKAGE_XENOMAI_COBALT
+       bool "Cobalt"
+       help
+         Select Cobalt core (dual kernel) for the Xenomai
+         userspace. Use this if you use a Xenomai-patched
+         Linux kernel.
+
+         If you want to use Cobalt core, your kernel must have
+         the Adeos and Xenomai patches applied to it. You can
+         add these through the BR2_LINUX_KERNEL_EXT_XENOMAI option
+         in the Linux Kernel Extensions menu.
+endchoice
+
 config BR2_PACKAGE_XENOMAI_TESTSUITE
        bool "Install testsuite"
        help
index c9e810e0516a717f1a79df1ce83d882af274c836..73d9617b1ff467abb3c88f004e7abe706e4cdab5 100644 (file)
@@ -23,6 +23,12 @@ XENOMAI_INSTALL_STAGING_OPTS = DESTDIR=$(STAGING_DIR) install-user
 
 XENOMAI_CONF_OPTS += --includedir=/usr/include/xenomai/ --disable-doc-install
 
+ifeq ($(BR2_PACKAGE_XENOMAI_MERCURY),y)
+XENOMAI_CONF_OPTS += --with-core=mercury
+else
+XENOMAI_CONF_OPTS += --with-core=cobalt
+endif
+
 define XENOMAI_REMOVE_DEVFILES
        for i in xeno-config xeno-info wrap-link.sh ; do \
                rm -f $(TARGET_DIR)/usr/bin/$$i ; \