package/rpcbind: use upstream systemd service files
authorJames Hilliard <james.hilliard1@gmail.com>
Mon, 12 Jul 2021 04:35:34 +0000 (22:35 -0600)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 20 Jul 2021 19:48:18 +0000 (21:48 +0200)
The overriden service files appear to have compatibility issues
with upstream rpcbind, don't replace the bundled service files.

We need to build with --enable-warmstarts as this is required
by the systemd service files.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/rpcbind/rpcbind.mk
package/rpcbind/rpcbind.service [deleted file]
package/rpcbind/rpcbind.socket [deleted file]

index d9f25e698e02df50d847ca851e56c40dc2b24310..725075f9624c55edacb7c8dfe322cb6f3925e37f 100644 (file)
@@ -17,19 +17,13 @@ RPCBIND_DEPENDENCIES += libtirpc host-pkgconf
 RPCBIND_CONF_OPTS += --with-rpcuser=root
 
 ifeq ($(BR2_INIT_SYSTEMD),y)
-RPCBIND_CONF_OPTS += --with-systemdsystemunitdir=/usr/lib/systemd/system
+RPCBIND_CONF_OPTS += --enable-warmstarts \
+       --with-systemdsystemunitdir=/usr/lib/systemd/system
 RPCBIND_DEPENDENCIES += systemd
 else
 RPCBIND_CONF_OPTS += --with-systemdsystemunitdir=no
 endif
 
-define RPCBIND_INSTALL_INIT_SYSTEMD
-       $(INSTALL) -m 0644 -D package/rpcbind/rpcbind.service \
-               $(TARGET_DIR)/usr/lib/systemd/system/rpcbind.service
-       $(INSTALL) -m 0644 -D package/rpcbind/rpcbind.socket \
-               $(TARGET_DIR)/usr/lib/systemd/system/rpcbind.socket
-endef
-
 define RPCBIND_INSTALL_INIT_SYSV
        $(INSTALL) -m 0755 -D package/rpcbind/S30rpcbind \
                $(TARGET_DIR)/etc/init.d/S30rpcbind
diff --git a/package/rpcbind/rpcbind.service b/package/rpcbind/rpcbind.service
deleted file mode 100644 (file)
index e41931d..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=RPC bind service
-Requires=rpcbind.socket
-
-[Service]
-Type=forking
-ExecStart=/usr/sbin/rpcbind
-
-[Install]
-Also=rpcbind.socket
diff --git a/package/rpcbind/rpcbind.socket b/package/rpcbind/rpcbind.socket
deleted file mode 100644 (file)
index d63c1d9..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-[Unit]
-Description=RPCbind Server Activation Socket
-
-[Socket]
-ListenStream=/var/run/rpcbind.sock
-
-[Install]
-WantedBy=sockets.target