toolchain/toolchain-external: update Arm ARM toolchain 10.3-2021.07
authorRomain Naour <romain.naour@gmail.com>
Tue, 31 Aug 2021 19:27:27 +0000 (21:27 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 16:20:45 +0000 (18:20 +0200)
Update to gcc 10.3, gdb 10.2, binutils 2.36.1, glibc 2.33.

Remove BR2_TOOLCHAIN_HAS_NATIVE_RPC since the support for obsolete
RPC was finally dropped in glibc in 2.32 (2020-08-04).

See "Release Note":
https://developer.arm.com/open-source/gnu-toolchain/gnu-a/downloads#

Tested with qemu_arm_vexpress_defconfig.

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
toolchain/toolchain-external/toolchain-external-arm-arm/Config.in
toolchain/toolchain-external/toolchain-external-arm-arm/toolchain-external-arm-arm.hash
toolchain/toolchain-external/toolchain-external-arm-arm/toolchain-external-arm-arm.mk

index e3bac38baa49e563221534921b86ac443adbbb94..0fbeba6aae4610fc601d405299399cdaeab39343 100644 (file)
@@ -4,7 +4,7 @@ comment "Arm toolchains available for Cortex-A with NEON + EABIhf"
        depends on !BR2_STATIC_LIBS
 
 config BR2_TOOLCHAIN_EXTERNAL_ARM_ARM
-       bool "Arm ARM 2020.11"
+       bool "Arm ARM 2021.07"
        depends on BR2_arm
        depends on BR2_ARM_CPU_ARMV7A || BR2_ARM_CPU_ARMV8A
        depends on BR2_ARM_CPU_HAS_NEON
@@ -13,15 +13,14 @@ config BR2_TOOLCHAIN_EXTERNAL_ARM_ARM
        depends on !BR2_STATIC_LIBS
        select BR2_TOOLCHAIN_EXTERNAL_GLIBC
        select BR2_TOOLCHAIN_HAS_SSP
-       select BR2_TOOLCHAIN_HAS_NATIVE_RPC
        select BR2_INSTALL_LIBSTDCPP
        select BR2_TOOLCHAIN_HEADERS_AT_LEAST_4_20
        select BR2_TOOLCHAIN_GCC_AT_LEAST_10
        select BR2_TOOLCHAIN_HAS_FORTRAN
        select BR2_TOOLCHAIN_HAS_OPENMP
        help
-         Arm toolchain for the ARM architecture. It uses GCC 10.2,
-         GDB 10.1, glibc 2.31, Binutils 2.35.1. It generates code
+         Arm toolchain for the ARM architecture. It uses GCC 10.3,
+         GDB 10.2, glibc 2.33, Binutils 2.36.1. It generates code
          that runs on all Cortex-A profile devices. The code
          generated uses the hard floating point calling convention,
          and uses the NEON FPU instructions.
index a46ed4e40c7f58d7867ecdffe40380d9b0535c0a..d58692de5368067d87487f54bf0c74b5d3a6a5a7 100644 (file)
@@ -1,4 +1,4 @@
-# From https://developer.arm.com/-/media/Files/downloads/gnu-a/10.2-2020.11/binrel/gcc-arm-10.2-2020.11-x86_64-arm-none-linux-gnueabihf.tar.xz.asc
-md5  14f706db78cfb43aafed9056174572b0  gcc-arm-10.2-2020.11-x86_64-arm-none-linux-gnueabihf.tar.xz
+# From https://developer.arm.com/-/media/Files/downloads/gnu-a/10.3-2021.07/binrel/gcc-arm-10.3-2021.07-x86_64-arm-none-linux-gnueabihf.tar.xz.asc
+md5  87ec580b290df2febc7c476f59484635  gcc-arm-10.3-2021.07-x86_64-arm-none-linux-gnueabihf.tar.xz
 # locally calculated
-sha256  102825ae56c9e00142d06f35d2bdd3299edb6060e84a275a25b095e66fd3fc2a  gcc-arm-10.2-2020.11-x86_64-arm-none-linux-gnueabihf.tar.xz
+sha256  aa074fa8371a4f73fecbd16bd62c8b1945f23289e26414794f130d6ccdf8e39c  gcc-arm-10.3-2021.07-x86_64-arm-none-linux-gnueabihf.tar.xz
index 88b6ae340380a047a7dd622ec52ed24cfe0a4270..43922051057dfdc42ce2676d39cbe5b2f8e50b5d 100644 (file)
@@ -4,9 +4,9 @@
 #
 ################################################################################
 
-TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION = 2020.11
-TOOLCHAIN_EXTERNAL_ARM_ARM_SITE = https://developer.arm.com/-/media/Files/downloads/gnu-a/10.2-$(TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION)/binrel
+TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION = 2021.07
+TOOLCHAIN_EXTERNAL_ARM_ARM_SITE = https://developer.arm.com/-/media/Files/downloads/gnu-a/10.3-$(TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION)/binrel
 
-TOOLCHAIN_EXTERNAL_ARM_ARM_SOURCE = gcc-arm-10.2-$(TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION)-x86_64-arm-none-linux-gnueabihf.tar.xz
+TOOLCHAIN_EXTERNAL_ARM_ARM_SOURCE = gcc-arm-10.3-$(TOOLCHAIN_EXTERNAL_ARM_ARM_VERSION)-x86_64-arm-none-linux-gnueabihf.tar.xz
 
 $(eval $(toolchain-external-package))