Update to uClibc 0.9.15. decouple kernel, toolchain, and uClibc.
authorEric Andersen <andersen@codepoet.org>
Wed, 28 Aug 2002 21:28:19 +0000 (21:28 -0000)
committerEric Andersen <andersen@codepoet.org>
Wed, 28 Aug 2002 21:28:19 +0000 (21:28 -0000)
 -Erik

Makefile
make/uclibc.mk
make/uclibc_toolchain.mk
make/user-mode-linux.mk
make/valgrind.mk

index 220feabee9f064ece1d2b50d8cdc6e64b8056ac4..c711196b9931ca92330ed8515bfafa0275c8a531 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,7 +39,7 @@ USE_UCLIBC_TOOLCHAIN:=false
 # Enable this to use the uClibc daily snapshot instead of a released
 # version.  Daily snapshots may contain new features and bugfixes. Or
 # they may not even compile at all, depending on what Erik is doing...
-USE_UCLIBC_SNAPSHOT:=true
+USE_UCLIBC_SNAPSHOT:=false
 
 # Enable this to use the busybox daily snapshot instead of a released
 # version.  Daily snapshots may contain new features and bugfixes. Or
@@ -58,7 +58,7 @@ ifeq ($(USE_UCLIBC_TOOLCHAIN),true)
 TARGETS=uclibc_toolchain
 endif
 
-TARGETS+=user-mode-linux busybox tinylogin #ncurses gdb strace valgrind
+TARGETS+=user-mode-linux busybox tinylogin ncurses gdb strace valgrind db
 
 # Pick your root filesystem type.
 TARGETS+=ext2root
index 5d856452d34238f433af6fdc32f03eef98cf034d..3b8418fcc2deddb87fff81437000470e16356258 100644 (file)
@@ -29,8 +29,8 @@ UCLIBC_DIR=$(BUILD_DIR)/uClibc
 UCLIBC_SOURCE=uClibc-snapshot.tar.bz2
 UCLIBC_SITE:=ftp://www.uclibc.org/uClibc
 else
-UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.14
-UCLIBC_SOURCE:=uClibc-0.9.14.tar.bz2
+UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.15
+UCLIBC_SOURCE:=uClibc-0.9.15.tar.bz2
 UCLIBC_SITE:=http://www.kernel.org/pub/linux/libs/uclibc
 endif
 #UCLIBC_PATCH=$(SOURCE_DIR)/uClibc.patch
@@ -66,7 +66,6 @@ $(UCLIBC_DIR)/Config: $(UCLIBC_DIR)/.unpacked
                --kernel_dir=$(LINUX_DIR) \
                --float=true \
                --c99_math=true \
-               --long_long=true \
                --float=true \
                --shadow=true \
                --threads=true \
index b07d3a821ea52781f52c6d2ed42fb96ea0b6b559..5642e465cc1a93947d413aaab4ea3eaa18237476 100644 (file)
@@ -33,10 +33,6 @@ HOSTCC:=gcc
 HAS_MMU:=true
 
 
-# Enable this to use the uClibc daily snapshot instead of a released
-# version.  Daily snapshots may contain new features and bugfixes. Or
-# they may not even compile at all, depending on what Erik is doing...
-USE_UCLIBC_SNAPSHOT:=true
 #############################################################
 #
 # You should probably leave this stuff alone unless you are
@@ -56,11 +52,11 @@ NATIVE_ARCH:= ${shell uname -m | sed \
                -e 's/sh[234].*/sh/' \
                -e 's/mips.*/mips/' \
                }
-ifeq ($(strip $(ARCH)),$(strip $(NATIVE_ARCH)))
-CROSSARG=
-else
+#ifeq ($(strip $(ARCH)),$(strip $(NATIVE_ARCH)))
+#CROSSARG=
+#else
 CROSSARG=--cross=$(STAGING_DIR)/bin/$(ARCH)-uclibc-
-endif
+#endif
 ifneq ($(HAS_MMU),true)
 NOMMU:=nommu
 endif
@@ -84,14 +80,14 @@ UCLIBC_DIR=$(BUILD_DIR)/uClibc
 UCLIBC_SOURCE=uClibc-snapshot.tar.bz2
 UCLIBC_SITE:=ftp://www.uclibc.org/uClibc
 else
-UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.14
-UCLIBC_SOURCE:=uClibc-0.9.14.tar.bz2
+UCLIBC_DIR:=$(BUILD_DIR)/uClibc-0.9.15
+UCLIBC_SOURCE:=uClibc-0.9.15.tar.bz2
 UCLIBC_SITE:=http://www.kernel.org/pub/linux/libs/uclibc
 endif
 
 GCC_SITE:=ftp://ftp.gnu.org/gnu/gcc/
-GCC_SOURCE:=gcc-3.1.1.tar.gz
-GCC_DIR:=$(BUILD_DIR)/gcc-3.1.1
+GCC_SOURCE:=gcc-3.2.tar.gz
+GCC_DIR:=$(BUILD_DIR)/gcc-3.2
 GCC_BUILD_DIR1:=$(BUILD_DIR)/gcc-initial
 GCC_BUILD_DIR2:=$(BUILD_DIR)/gcc-final
 
@@ -122,7 +118,7 @@ $(BUILD_DIR)/.setup:
 # Setup some initial stuff
 #
 #############################################################
-uclibc_toolchain: gcc_final
+uclibc_toolchain: uclibc gcc_final
 
 uclibc_toolchain-clean: gcc_final-clean uclibc-clean gcc_initial-clean binutils-clean
 
@@ -130,27 +126,6 @@ uclibc_toolchain-dirclean: gcc_final-dirclean uclibc-dirclean gcc_initial-dircle
 
 
 
-#############################################################
-#
-# Setup the kernel headers, but don't compile anything for the target yet,
-# since we still need to build a cross-compiler to do that little task for
-# us...  Try to work around this little chicken-and-egg problem..
-#
-#############################################################
-ifeq ($(LINUX_DIR),)
-LINUX_DIR:=$(BUILD_DIR)/linux
-endif
-$(LINUX_DIR)/.cross_compiler_set: $(BUILD_DIR)/.setup $(LINUX_DIR)/.configured
-       #If we were cross compiling the kernel, we would need to do this,
-       # but for UserMode Linux, we can skip this step....
-       #perl -i -p -e "s,^CROSS_COMPILE.*,\
-       #       CROSS_COMPILE=$(STAGING_DIR)/bin/$(ARCH)-uclibc-,g;" \
-       #       $(LINUX_DIR)/Makefile
-       touch $(LINUX_DIR)/.cross_compiler_set
-
-linux_headers: $(LINUX_DIR)/.cross_compiler_set
-
-
 #############################################################
 #
 # build binutils
@@ -293,7 +268,6 @@ $(UCLIBC_DIR)/.configured: $(UCLIBC_DIR)/.unpacked
                --kernel_dir=$(LINUX_DIR) \
                --float=true \
                --c99_math=true \
-               --long_long=true \
                --float=true \
                --shadow=true \
                --threads=true \
@@ -453,8 +427,8 @@ $(BUILD_DIR)/.stripped: $(BUILD_DIR)/.shuffled
                -R .note -R .comment $(STAGING_DIR)/lib/*.so*;
        touch $(BUILD_DIR)/.stripped
 
-#gcc_final: uclibc $(BUILD_DIR)/.stripped
-gcc_final: uclibc $(BUILD_DIR)/.shuffled
+#gcc_final: $(BUILD_DIR)/.stripped
+gcc_final: $(BUILD_DIR)/.shuffled
 
 gcc_final-clean:
        rm -rf $(GCC_BUILD_DIR2)
index 5b0750230c24e64c809b7ebf00c319544e41657f..79968a76948a8df54cb2dde744b9d24af3872fe7 100644 (file)
@@ -55,3 +55,12 @@ user-mode-linux_clean: clean
 user-mode-linux-dirclean:
        rm -rf $(UMLINUX_DIR)
 
+#############################################################
+#
+# Setup the kernel headers, but don't compile anything for the target yet,
+# since we still need to build a cross-compiler to do that little task for
+# us...  Try to work around this little chicken-and-egg problem..
+#
+#############################################################
+linux_headers: $(UMLINUX_DIR)/.configured
+
index 38c0f404e63be3d247f89c94bba0452221b4dd55..50ffa23aada9723c02aafd4e19c9ed985ef55fc6 100644 (file)
@@ -5,8 +5,8 @@
 #############################################################
 
 VALGRIND_SITE:=http://developer.kde.org/~sewardj
-VALGRIND_DIR:=$(BUILD_DIR)/valgrind-1.0.0
-VALGRIND_SOURCE:=valgrind-1.0.0.tar.bz2
+VALGRIND_DIR:=$(BUILD_DIR)/valgrind-1.0.1
+VALGRIND_SOURCE:=valgrind-1.0.1.tar.bz2
 VALGRIND_PATCH:=$(SOURCE_DIR)/valgrind.patch
 
 $(DL_DIR)/$(VALGRIND_SOURCE):