lcdapi: new package
authorSimon Dawson <spdawson@gmail.com>
Fri, 26 Oct 2012 06:32:48 +0000 (06:32 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sat, 27 Oct 2012 21:31:15 +0000 (23:31 +0200)
Signed-off-by: Simon Dawson <spdawson@gmail.com>
Acked-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tested-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/Config.in
package/lcdapi/Config.in [new file with mode: 0644]
package/lcdapi/lcdapi.mk [new file with mode: 0644]

index 1650c71488693e5bbfe6519378ba433cdd638abe..6ebf2cef8059c48973c4441f60293e81340b18b5 100644 (file)
@@ -392,6 +392,7 @@ endmenu
 
 menu "Hardware handling"
 source "package/ccid/Config.in"
+source "package/lcdapi/Config.in"
 source "package/libaio/Config.in"
 source "package/libraw1394/Config.in"
 source "package/tslib/Config.in"
diff --git a/package/lcdapi/Config.in b/package/lcdapi/Config.in
new file mode 100644 (file)
index 0000000..5c997d1
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LCDAPI
+       bool "lcdapi"
+       depends on BR2_INSTALL_LIBSTDCPP
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         C++ client API for lcdproc, containing a set of widget classes.
+
+         https://github.com/spdawson/lcdapi
+
+comment "lcdapi requires a toolchain with C++ and thread support enabled"
+       depends on !BR2_INSTALL_LIBSTDCPP || !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/lcdapi/lcdapi.mk b/package/lcdapi/lcdapi.mk
new file mode 100644 (file)
index 0000000..8125018
--- /dev/null
@@ -0,0 +1,41 @@
+#############################################################
+#
+# lcdapi
+#
+#############################################################
+LCDAPI_VERSION = v0.3
+LCDAPI_SITE = http://github.com/spdawson/lcdapi/tarball/$(LCDAPI_VERSION)
+LCDAPI_LICENSE = LGPLv2.1+
+LCDAPI_LICENSE_FILES = COPYING
+
+LCDAPI_INSTALL_STAGING = YES
+
+define LCDAPI_BUILD_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
+endef
+
+define LCDAPI_INSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               DESTDIR="$(STAGING_DIR)" install
+endef
+
+define LCDAPI_INSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               DESTDIR="$(TARGET_DIR)" install
+endef
+
+define LCDAPI_UNINSTALL_STAGING_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               DESTDIR="$(STAGING_DIR)" uninstall
+endef
+
+define LCDAPI_UNINSTALL_TARGET_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) \
+               DESTDIR="$(TARGET_DIR)" uninstall
+endef
+
+define LCDAPI_CLEAN_CMDS
+       $(TARGET_MAKE_ENV) $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D) clean
+endef
+
+$(eval $(generic-package))