package/tzdata: install a default localtime
authorYann E. MORIN <yann.morin.1998@free.fr>
Tue, 7 Jan 2014 22:46:06 +0000 (23:46 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Thu, 9 Jan 2014 20:23:05 +0000 (21:23 +0100)
Add an option to install a default localtime.

since tzdata only makes sense for (e)glibc, we don't care
that we install timezone files that uClibc can't understand.

Signed-off-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/tzdata/Config.in
package/tzdata/tzdata.mk

index 1be68149b5def5c832c4c8dc425a61aeafb86b98..c0ede1f55ce74b5917de6a38f908302bf4af1ff6 100644 (file)
@@ -23,4 +23,14 @@ config BR2_PACKAGE_TZDATA_ZONELIST
          The full list is the list of files in the time zone database source,
          not including the build and .tab files.
 
+config BR2_PACKAGE_TZDATA_LOCALTIME
+       string "default local time"
+       help
+         The time zone to install as the default local time, expressed as a
+         tzdata location, such as:
+           GMT, Europe/Paris, America/New_York, Pacific/Wallis...
+
+         If empty, no local time will be set, and the dates will be
+         expressed in UTC.
+
 endif
index 1cb5b3f00f812023230114f25045ffd3213cfadf..74263e173eca7829f40ccd7080ee9ebea3249bde 100644 (file)
@@ -39,8 +39,14 @@ define TZDATA_INSTALL_TARGET_CMDS
        cp -a $(@D)/_output/* $(TARGET_DIR)/usr/share/zoneinfo
        cd $(TARGET_DIR)/usr/share/zoneinfo;    \
        for zone in posix/*; do                 \
-           ln -sfn "$${zone}" "$${zone##*/}";    \
+           ln -sfn "$${zone}" "$${zone##*/}";  \
        done
+       if [ -n "$(BR2_PACKAGE_TZDATA_LOCALTIME)" ]; then                   \
+           cd $(TARGET_DIR)/etc;                                           \
+           ln -sf ../usr/share/zoneinfo/$(BR2_PACKAGE_TZDATA_LOCALTIME)    \
+                  localtime;                                               \
+           echo "$(BR2_PACKAGE_TZDATA_LOCALTIME)" >timezone;               \
+       fi
 endef
 
 $(eval $(generic-package))