Add options to select what gfx and mouse drivers are compiled in.
authorArnar Mar Sigurðsson <antab@valka.is>
Fri, 31 Oct 2008 17:17:23 +0000 (17:17 -0000)
committerArnar Mar Sigurðsson <antab@valka.is>
Fri, 31 Oct 2008 17:17:23 +0000 (17:17 -0000)
Note to tslib users: You now have to select the tslib mouse driver to build it.

package/qtopia4/Config.gfx.in [new file with mode: 0644]
package/qtopia4/Config.in
package/qtopia4/Config.mouse.in [new file with mode: 0644]
package/qtopia4/Config.sql.in
package/qtopia4/qtopia4.mk

diff --git a/package/qtopia4/Config.gfx.in b/package/qtopia4/Config.gfx.in
new file mode 100644 (file)
index 0000000..572e810
--- /dev/null
@@ -0,0 +1,23 @@
+menu "Graphics drivers"
+
+config BR2_PACKAGE_QTOPIA4_GFX_LINUXFB
+       bool "Linux Framebuffer"
+       default y
+
+config BR2_PACKAGE_QTOPIA4_GFX_TRANSFORMED
+       bool "Transformed"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_GFX_QVFB
+       bool "Qt Virtual Framebuffer"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_GFX_VNC
+       bool "VNC"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_GFX_MULTISCREEN
+       bool "multiscreen"
+       default y
+
+endmenu
index 866184c18a5c9f675fa51ba15502e8285b842c02..1c2f948877b41ad9a80bf0c0e5da4c19f808584c 100644 (file)
@@ -224,13 +224,9 @@ config BR2_PACKAGE_QTOPIA4_EMB_PLATFORM
        help
          The target platform.
 
-menuconfig BR2_PACKAGE_QTOPIA4_SQL_MODULE
-       bool "SQL Module"
-       help
-         Compile Qtopia SQL Module
-if BR2_PACKAGE_QTOPIA4_SQL_MODULE
 source "package/qtopia4/Config.sql.in"
-endif
+source "package/qtopia4/Config.gfx.in"
+source "package/qtopia4/Config.mouse.in"
 
 config BR2_PACKAGE_QTOPIA4_XMLPATTERNS
        bool "XML Patterns Module"
diff --git a/package/qtopia4/Config.mouse.in b/package/qtopia4/Config.mouse.in
new file mode 100644 (file)
index 0000000..5ca4046
--- /dev/null
@@ -0,0 +1,31 @@
+menu "Mouse drivers"
+
+config BR2_PACKAGE_QTOPIA4_MOUSE_PC
+       bool "pc"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_MOUSE_BUS
+       bool "bus"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_MOUSE_LINUXTP
+       bool "linuxtp"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_MOUSE_YOPY
+       bool "yopy"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_MOUSE_VR41XX
+       bool "vxr41xx"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_MOUSE_TSLIB
+       bool "tslib"
+       default n
+
+config BR2_PACKAGE_QTOPIA4_MOUSE_QVFB
+       bool "qvfb"
+       default n
+
+endmenu
index ae3cf3c7c6c08f7239a4d1217c1416609b742b5e..881f7edb626883bc7fec7f9b751add0dd46de973 100644 (file)
@@ -1,3 +1,9 @@
+menuconfig BR2_PACKAGE_QTOPIA4_SQL_MODULE
+    bool "SQL Module"
+    help
+      Compile Qtopia SQL Module
+
+if BR2_PACKAGE_QTOPIA4_SQL_MODULE
 config BR2_PACKAGE_QTOPIA4_MYSQL
        bool "MySQL Driver"
        help
@@ -33,4 +39,4 @@ config BR2_PACKAGE_QTOPIA4_SQLITE2
        help
          Build SQLite 2 driver
          If unsure, say n.
-
+endif
index de3bf4d2de55202d582980f13639ef08bc0d34ef..cadaaa661d55213638c9ef2bb73c6d6d1066ec63 100644 (file)
@@ -65,12 +65,68 @@ else
 QTOPIA4_CONFIGURE+= -no-qt3support
 endif
 
-ifeq ($(BR2_PACKAGE_TSLIB),y)
-QTOPIA4_CONFIGURE+= -qt-mouse-tslib
+
+### Display drivers
+ifeq ($(BR2_PACKAGE_QTOPIA4_GFX_LINUXFB),y)
+QTOPIA4_CONFIGURE += -qt-gfx-linuxfb
+else
+QTOPIA4_CONFIGURE += -no-gfx-linuxfb
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_GFX_TRANSFORMED),y)
+QTOPIA4_CONFIGURE += -qt-gfx-transformed
+else
+QTOPIA4_CONFIGURE += -no-gfx-transformed
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_GFX_QVFB),y)
+QTOPIA4_CONFIGURE += -qt-gfx-qvfb
+else
+QTOPIA4_CONFIGURE += -no-gfx-qvfb
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_GFX_VNC),y)
+QTOPIA4_CONFIGURE += -qt-gfx-vnc
+else
+QTOPIA4_CONFIGURE += -no-gfx-vnc
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_GFX_MULTISCREEN),y)
+QTOPIA4_CONFIGURE += -qt-gfx-multiscreen
+else
+QTOPIA4_CONFIGURE += -no-gfx-multiscreen
+endif
+
+### Mouse drivers
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_PC),y)
+QTOPIA4_CONFIGURE += qt-mouse-pc
+else
+QTOPIA4_CONFIGURE += -no-mouse-pc
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_BUS),y)
+QTOPIA4_CONFIGURE += qt-mouse-bus
+else
+QTOPIA4_CONFIGURE += -no-mouse-bus
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_LINUXTP),y)
+QTOPIA4_CONFIGURE += qt-mouse-linuxtp
+else
+QTOPIA4_CONFIGURE += -no-mouse-linuxtp
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_YOPY),y)
+QTOPIA4_CONFIGURE += qt-mouse-yopy
+else
+QTOPIA4_CONFIGURE += -no-mouse-yopy
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_VR41XX),y)
+QTOPIA4_CONFIGURE += qt-mouse-vr41xx
+else
+QTOPIA4_CONFIGURE += -no-mouse-vr41xx
+endif
+ifeq ($(BR2_PACKAGE_QTOPIA4_MOUSE_TSLIB),y)
+QTOPIA4_CONFIGURE += qt-mouse-tslib
 QTOPIA4_DEP_LIBS+=tslib
 QTOPIA4_TSLIB_DEB="-D TSLIBMOUSEHANDLER_DEBUG"
 QTOPIA4_TSLIB_DEB:=$(strip $(subst ",, $(QTOPIA4_TSLIB_DEB)))
 #"))
+else
+QTOPIA4_CONFIGURE += -no-mouse-tslib
 endif
 
 ifeq ($(BR2_PACKAGE_QTOPIA4_DEBUG),y)