Improvements to the package conversion status script
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 26 Jul 2010 13:15:14 +0000 (15:15 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Mon, 26 Jul 2010 20:48:41 +0000 (22:48 +0200)
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
scripts/pkg-stats

index 1174ef04c26d39e10cdc6063ddfcdb5dbdf6d23d..01af89de09937a10e4d247e978c2f60d623b453b 100755 (executable)
@@ -36,6 +36,12 @@ td {
 td.centered {
   text-align: center;
 }
+tr.wrong td {
+  background: #ff9a69;
+}
+tr.correct td {
+  background: #d2ffc4;
+}
 </style>
 </head>
 
@@ -78,12 +84,7 @@ for i in $(find package/ -name '*.mk') ; do
        continue
     fi
 
-    found=0
-
-    echo "<tr>"
-    echo "<td>$cnt</td>"
     cnt=$((cnt+1))
-    echo "<td>$i</td>"
 
     is_auto_host=0
     is_auto_target=0
@@ -92,18 +93,74 @@ for i in $(find package/ -name '*.mk') ; do
     is_manual_target=0
     is_manual_host=0
 
-    echo "<td class=\"centered\">"
     if grep -E "\(call AUTOTARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
        is_auto_host=1
+    fi
+
+    if grep -E "\(call AUTOTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+       is_auto_target=1
+    fi
+
+    if grep -E "\(call GENTARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
+       is_pkg_host=1
+    fi
+
+    if grep -E "\(call GENTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
+       is_pkg_target=1
+    fi
+
+    pkg=$(basename $i)
+    pkg=${pkg%.mk}
+
+    if grep "^host-$pkg:" $i > /dev/null ; then
+       is_manual_host=1
+    fi
+
+    if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 ; then
+       is_manual_target=1
+    fi
+
+    tasks=""
+
+    if [ $is_manual_target -eq 1 ] ; then
+       if grep "/configure" $i > /dev/null ; then
+           tasks=$tasks"<li>convert package to autotools ?</li>"
+           convert_to_target_autotools=$((convert_to_target_autotools+1))
+       else
+           tasks=$tasks"<li>convert to generic target</li>"
+           convert_to_generic_target=$((convert_to_generic_target+1))
+       fi
+    fi
+
+    if [ $is_manual_host -eq 1 ]; then
+       if grep "/configure" $i > /dev/null ; then
+           tasks=$tasks"<li>convert package to autotools ?</li>"
+           convert_to_host_autotools=$((convert_to_host_autotools+1))
+       else
+           tasks=$tasks"<li>convert to generic host</li>"
+           convert_to_generic_host=$((convert_to_generic_host+1))
+       fi
+    fi
+
+    if test -n "$tasks" ; then
+       echo "<tr class=\"wrong\">"
+    else
+       echo "<tr class=\"correct\">"
+    fi
+
+    echo "<td>$cnt</td>"
+    echo "<td>$i</td>"
+
+    echo "<td class=\"centered\">"
+    if [ $is_auto_host -eq 1 ] ; then
        echo "<b>YES</b>"
     else
        echo "NO"
     fi
+    echo "</td>"
 
     echo "<td class=\"centered\">"
-    if grep -E "\(call AUTOTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
-       found=1
-       is_auto_target=1
+    if [ $is_auto_target -eq 1 ] ; then
        echo "<b>YES</b>"
     else
        echo "NO"
@@ -111,9 +168,7 @@ for i in $(find package/ -name '*.mk') ; do
     echo "</td>"
 
     echo "<td class=\"centered\">"
-    if grep -E "\(call GENTARGETS,[^,]*,[^,]*,host\)" $i > /dev/null ; then
-       found=1
-       is_pkg_host=1
+    if [ $is_pkg_host -eq 1 ] ; then
        echo "<b>YES</b>"
     else
        echo "NO"
@@ -121,22 +176,15 @@ for i in $(find package/ -name '*.mk') ; do
     echo "</td>"
 
     echo "<td class=\"centered\">"
-    if grep -E "\(call GENTARGETS,[^,]*,[^,]*(,target|)\)" $i > /dev/null ; then
-       found=1
-       is_pkg_target=1
+    if [ $is_pkg_target -eq 1 ] ; then
        echo "<b>YES</b>"
     else
        echo "NO"
     fi
     echo "</td>"
 
-    pkg=$(basename $i)
-    pkg=${pkg%.mk}
-
     echo "<td class=\"centered\">"
-    if grep "^host-$pkg:" $i > /dev/null ; then
-       found=1
-       is_manual_host=1
+    if [ $is_manual_host -eq 1 ] ; then
        echo "<b>YES</b>"
     else
        echo "NO"
@@ -144,9 +192,7 @@ for i in $(find package/ -name '*.mk') ; do
     echo "</td>"
 
     echo "<td class=\"centered\">"
-    if test $is_pkg_target -eq 0 -a $is_auto_target -eq 0 ; then
-       found=1
-       is_manual_target=1
+    if [ $is_manual_target -eq 1 ] ; then
        echo "<b>YES</b>"
     else
        echo "NO"
@@ -155,22 +201,7 @@ for i in $(find package/ -name '*.mk') ; do
 
     echo "<td>"
     echo "<ul>"
-    if grep "/configure" $i > /dev/null ; then
-       echo "<li>convert package to autotools ?</li>"
-       convert_to_autotools=$((convert_to_autotools+1))
-    else
-       if [ $is_manual_target -eq 1 ]; then
-           echo "<li>convert to generic target</li>"
-           convert_to_generic_target=$((convert_to_generic_target+1))
-       fi
-       if [ $is_manual_host -eq 1 ]; then
-           echo "<li>convert to generic host</li>"
-           convert_to_generic_host=$((convert_to_generic_host+1))
-       fi
-    fi
-    if [ $found -eq 0 ] ; then
-       echo "<li>look manually</li>"
-    fi
+    echo $tasks
     echo "</ul>"
     echo "</td>"
 
@@ -189,8 +220,12 @@ echo "<td>Packages to convert to generic host</td>"
 echo "<td>$convert_to_generic_host</td>"
 echo "</tr>"
 echo "<tr>"
-echo "<td>Packages to convert to autotools</td>"
-echo "<td>$convert_to_autotools</td>"
+echo "<td>Packages to convert to target autotools</td>"
+echo "<td>$convert_to_target_autotools</td>"
+echo "</tr>"
+echo "<tr>"
+echo "<td>Packages to convert to host autotools</td>"
+echo "<td>$convert_to_host_autotools</td>"
 echo "</tr>"
 echo "<tr>"
 echo "<td>TOTAL</td>"