utils/scanpypi: fix flake8 errors
authorArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 27 Jul 2021 21:29:07 +0000 (23:29 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Tue, 27 Jul 2021 21:29:07 +0000 (23:29 +0200)
Commit e43c0509442c746bea305aa2b0a5f7ff5adfd142 introduced two flake8
errors:

utils/scanpypi:300:26: E231 missing whitespace after ','
utils/scanpypi:302:9: F841 local variable 'setup' is assigned to but never used

The first one is easily fixed. The second one needs a little bit of
explanation. Before commit e43c0509, the return value of
imp.load_module() was used to be able to explicitly call the 'setup'
function in it in case the metadata was not populated. Since that
commit, calling that function is no longer needed, since setup.py is
executed in exactly the same way as when it's run from the command line,
so if that doesn't work, it's completely broken anyway. Therefore, we
can simply discard the return value of imp.load_module().

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
utils/scanpypi

index 04c43f9311ebb2d9f88b83ebf6ae83fed505cb4e..9dede4e11935705f1e4b50ffd6d0ff10464e1392 100755 (executable)
@@ -297,9 +297,9 @@ class BuildrootPackage():
         """
         current_dir = os.getcwd()
         os.chdir(self.tmp_extract)
-        sys.path.insert(0,self.tmp_extract)
+        sys.path.insert(0, self.tmp_extract)
         s_file, s_path, s_desc = imp.find_module('setup', [self.tmp_extract])
-        setup = imp.load_module('__main__', s_file, s_path, s_desc)
+        imp.load_module('__main__', s_file, s_path, s_desc)
         if self.metadata_name in self.setup_args:
             pass
         elif self.metadata_name.replace('_', '-') in self.setup_args: