package/smcroute: prune old smcroute compat script
authorJoachim Wiberg <troglobit@gmail.com>
Mon, 30 Aug 2021 15:30:56 +0000 (17:30 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 11 Sep 2021 14:29:20 +0000 (16:29 +0200)
Long ago, before SMCRoute had yet become a proper daemon and standalone
control tool, it was both.  After the metamorphosis commands and options
had changed, a compat script was added to provide a smooth transition.

The compat script is still shipped in the tarball, and installed, but
only Debian still relies on it, so we prune it here to keep confusion
to a minimum, hopefully.

Signed-off-by: Joachim Wiberg <troglobit@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/smcroute/smcroute.mk

index 9cce0acbbccaa0e97fad120c79ee46956b992193..e8fc54bb42db5e430704f55130dbb90141403159 100644 (file)
@@ -24,4 +24,10 @@ define SMCROUTE_INSTALL_INIT_SYSV
                $(TARGET_DIR)/etc/init.d/S41smcroute
 endef
 
+define SMCROUTE_PRUNE_COMPAT_SCRIPT
+       rm -f $(TARGET_DIR)/usr/sbin/smcroute
+endef
+
+SMCROUTE_POST_INSTALL_TARGET_HOOKS += SMCROUTE_PRUNE_COMPAT_SCRIPT
+
 $(eval $(autotools-package))