python-pigpio: new package
authorGrzegorz Blach <grzegorz@blach.pl>
Fri, 28 Sep 2018 18:00:34 +0000 (20:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Tue, 9 Oct 2018 13:35:42 +0000 (15:35 +0200)
Pigpio is a Python module for the Raspberry Pi
which talks to the pigpio daemon to allow control
of the general purpose input outputs (GPIO).

http://abyz.co.uk/rpi/pigpio/python.html

Signed-off-by: Grzegorz Blach <grzegorz@blach.pl>
[Thomas: use proper SPDX license tag]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-pigpio/Config.in [new file with mode: 0644]
package/python-pigpio/python-pigpio.hash [new file with mode: 0644]
package/python-pigpio/python-pigpio.mk [new file with mode: 0644]

index 09d7138827451cc4728490abd38c658d5aeaa71d..824f3a3c585ba2114d91a4d6cec7332b52e9015c 100644 (file)
@@ -924,6 +924,7 @@ N:  Grzegorz Blach <grzegorz@blach.pl>
 F:     package/pigpio/
 F:     package/python-falcon/
 F:     package/python-mimeparse/
+F:     package/python-pigpio/
 
 N:     Guillaume Gardet <guillaume.gardet@oliseo.fr>
 F:     package/c-icap/
index 09e281eb3903320f99bb2c92d409efb56e7ef976..77e5f4cc395c9c2963d44e09f402343c4b99c627 100644 (file)
@@ -922,6 +922,7 @@ menu "External python modules"
        source "package/python-pathvalidate/Config.in"
        source "package/python-pexpect/Config.in"
        source "package/python-pickleshare/Config.in"
+       source "package/python-pigpio/Config.in"
        source "package/python-pillow/Config.in"
        source "package/python-pip/Config.in"
        source "package/python-portend/Config.in"
diff --git a/package/python-pigpio/Config.in b/package/python-pigpio/Config.in
new file mode 100644 (file)
index 0000000..08c37cb
--- /dev/null
@@ -0,0 +1,8 @@
+config BR2_PACKAGE_PYTHON_PIGPIO
+       bool "python-pigpio"
+       help
+         Pigpio is a Python module for the Raspberry Pi
+         which talks to the pigpio daemon to allow control
+         of the general purpose input outputs (GPIO).
+
+         http://abyz.co.uk/rpi/pigpio/python.html
diff --git a/package/python-pigpio/python-pigpio.hash b/package/python-pigpio/python-pigpio.hash
new file mode 100644 (file)
index 0000000..a0ef093
--- /dev/null
@@ -0,0 +1,3 @@
+# md5, sha256 from https://pypi.org/pypi/pigpio/json
+md5    32d7d5e2e042fb4f503b93858712e7ad  pigpio-1.40.post1.tar.gz
+sha256 38bdc1b4d58898e7b4a69de3b0d90e8e8ccd851ac7d03e30791769475ffd941f  pigpio-1.40.post1.tar.gz
diff --git a/package/python-pigpio/python-pigpio.mk b/package/python-pigpio/python-pigpio.mk
new file mode 100644 (file)
index 0000000..7c4527a
--- /dev/null
@@ -0,0 +1,13 @@
+################################################################################
+#
+# python-pigpio
+#
+################################################################################
+
+PYTHON_PIGPIO_VERSION = 1.40.post1
+PYTHON_PIGPIO_SOURCE = pigpio-$(PYTHON_PIGPIO_VERSION).tar.gz
+PYTHON_PIGPIO_SITE = https://files.pythonhosted.org/packages/da/91/80c893c398bc6805592f44267bbf4bf88323de3db0f5e8f94b0fa8e28426
+PYTHON_PIGPIO_SETUP_TYPE = setuptools
+PYTHON_PIGPIO_LICENSE = Unlicense
+
+$(eval $(python-package))