package/gcc: transition PowerPC 32 to secureplt
authorMatt Weber <matthew.weber@rockwellcollins.com>
Wed, 23 Sep 2020 15:29:08 +0000 (10:29 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 23 Sep 2020 18:47:02 +0000 (20:47 +0200)
PowerPC has two PLT models: BSS-PLT and Secure-PLT. BSS-PLT uses
runtime code generation to generate the PLT stubs. Secure-PLT was
introduced with GCC 4.1 and Binutils 2.17 (base has GCC 4.2.1 and
Binutils 2.17), and is a more secure PLT format, using a read-only
linkage table, with the dynamic linker populating a non-executable
index table.

References to other distro/BSD transitions:
  https://patchwork.openembedded.org/patch/106621/
  https://reviews.freebsd.org/D20598

Fixes a bug observed when creating SELinux policy where all apps
require execmem because the heap requires execute before this change.

Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gcc/gcc.mk

index b834269adcac62d61a074ccc1c916228ae1bbdba..df5bf22b96f332ce054277a08d3e571782bf36b6 100644 (file)
@@ -223,6 +223,13 @@ HOST_GCC_COMMON_CONF_OPTS += \
        --with-long-double-128
 endif
 
+# Set default to Secure-PLT to prevent run-time
+# generation of PLT stubs (supports RELRO and
+# SELinux non-exemem capabilities)
+ifeq ($(BR2_powerpc),y)
+HOST_GCC_COMMON_CONF_OPTS += --enable-secureplt
+endif
+
 # PowerPC64 big endian by default uses the elfv1 ABI, and PowerPC 64
 # little endian by default uses the elfv2 ABI. However, musl has
 # decided to use the elfv2 ABI for both, so we force the elfv2 ABI for