package/acsccid: needs iconv
authorBernd Kuhls <bernd.kuhls@t-online.de>
Wed, 30 Oct 2019 05:37:50 +0000 (06:37 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 8 Dec 2019 13:31:26 +0000 (14:31 +0100)
Upstream commit
https://github.com/acshk/acsccid/commit/5672d821ba96deb6c0c11060e4de0c9dab9b21c7
added "include <iconv.h>"

Fixes:
http://autobuild.buildroot.net/results/04e/04eac264718a47c550bb48b3c36314751fb4de91/

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/acsccid/Config.in
package/acsccid/acsccid.mk

index 90624ee797602726e23816eed7e6ec343b92a4c6..74dd6de295ad963e6e1649755a2092e738c895f0 100644 (file)
@@ -3,6 +3,7 @@ config BR2_PACKAGE_ACSCCID
        depends on BR2_TOOLCHAIN_HAS_THREADS # pcsc-lite, libusb
        depends on BR2_USE_MMU # pcsc-lite
        depends on !BR2_STATIC_LIBS # pcsc-lite
+       select BR2_PACKAGE_LIBICONV if !BR2_ENABLE_LOCALE
        select BR2_PACKAGE_PCSC_LITE
        # Even though there is a --disable-libusb option, it has in
        # fact no effect, and acsccid really requires libusb.
index abb25ac3be9b9c079528144d386118f617db67b1..28a31b95a3bb821399cec2c5b0fd3261b741f888 100644 (file)
@@ -13,4 +13,8 @@ ACSCCID_INSTALL_STAGING = YES
 ACSCCID_DEPENDENCIES = pcsc-lite host-flex host-pkgconf libusb
 ACSCCID_CONF_OPTS = --enable-usbdropdir=/usr/lib/pcsc/drivers
 
+ifeq ($(BR2_PACKAGE_LIBICONV),y)
+ACSCCID_DEPENDENCIES += libiconv
+endif
+
 $(eval $(autotools-package))