Remove configuration item for git commit ID, as our patches are version-specific.
authorHamish Moffatt <hamish@cloud.net.au>
Tue, 8 Apr 2008 04:18:11 +0000 (04:18 -0000)
committerHamish Moffatt <hamish@cloud.net.au>
Tue, 8 Apr 2008 04:18:11 +0000 (04:18 -0000)
Upgrade to a newer version than the previous default.
Fix parallel compile issue.
Fix issue with quoting of URL.

package/mtd/Config.in
package/mtd/mtd-utils.git/mtd-utils-all-argp.patch [deleted file]
package/mtd/mtd-utils.git/mtd.mk

index 6013a8ff4f2d2e704523250da907e7d172d72b5c..7e43ac3c5f4bbe37e117ca9c9c5024a0b1940bcc 100644 (file)
@@ -37,18 +37,6 @@ config BR2_PACKAGE_MTD_UTILS_GIT
 
 endchoice
 
-config BR2_PACKAGE_MTD_UTILS_GIT_COMMIT_ID
-       string  "Commit ID to use"
-       default "e6088d987c545d60a86e1f44836ab8ba072fffd9"
-       depends on BR2_PACKAGE_MTD_UTILS_GIT
-       help
-         If you wish to use the mtd-utils.git tree as of a specific
-         commit, you can enter the commit ID here (for example,
-         e6088d987c545d60a86e1f44836ab8ba072fffd9). 
-
-         Alternatively you can specify HEAD. Note that the current
-         HEAD will be downloaded but won't be tracked when it changes.
-
 comment "MTD tools selection"
        depends BR2_PACKAGE_MTD
 
diff --git a/package/mtd/mtd-utils.git/mtd-utils-all-argp.patch b/package/mtd/mtd-utils.git/mtd-utils-all-argp.patch
deleted file mode 100644 (file)
index 04ea332..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- mtd-utils-e6088d987c545d60a86e1f44836ab8ba072fffd9/ubi-utils/new-utils/src/ubicrc32.c.orig 2008-03-26 16:08:13.000000000 +1100
-+++ mtd-utils-e6088d987c545d60a86e1f44836ab8ba072fffd9/ubi-utils/new-utils/src/ubicrc32.c      2008-03-26 16:08:20.000000000 +1100
-@@ -26,7 +26,6 @@
- #include <stdint.h>
- #include <stdlib.h>
- #include <getopt.h>
--#include <argp.h>
- #include <unistd.h>
- #include <mtd/ubi-header.h>
index 79512abd56d084ab4a557a03113c73e4ff08f649..df32f53341fad41443f775a29b3d10b07f3c5c4e 100644 (file)
@@ -3,8 +3,7 @@
 # mtd provides jffs2 utilities
 #
 #############################################################
-MTD_VERSION:=$(strip $(subst ",, $(BR2_PACKAGE_MTD_UTILS_GIT_COMMIT_ID)))
-#"))
+MTD_VERSION:=fcb52ccc99679460640386c297023f852b108f68
 MTD_SOURCE:=mtd-utils-$(MTD_VERSION).tar.gz
 MTD_URL:=http://git.infradead.org/mtd-utils.git?a=snapshot;h=$(MTD_VERSION);sf=tgz
 MTD_HOST_DIR:= $(TOOL_BUILD_DIR)/mtd-utils-$(MTD_VERSION)
@@ -22,7 +21,7 @@ MKFS_JFFS2 := $(MTD_HOST_DIR)/mkfs.jffs2
 SUMTOOL := $(MTD_HOST_DIR)/sumtool
 
 $(DL_DIR)/$(MTD_SOURCE):
-       $(WGET) -O $(DL_DIR)/$(MTD_SOURCE) $(MTD_URL)
+       $(WGET) -O $(DL_DIR)/$(MTD_SOURCE) "$(MTD_URL)"
 
 $(MTD_HOST_DIR)/.unpacked: $(DL_DIR)/$(MTD_SOURCE)
        $(MTD_CAT) $(DL_DIR)/$(MTD_SOURCE) | tar -C $(TOOL_BUILD_DIR) $(TAR_OPTIONS) -
@@ -64,6 +63,7 @@ mtd-host-dirclean:
 #############################################################
 $(MTD_DIR)/.unpacked: $(DL_DIR)/$(MTD_SOURCE)
        $(MTD_CAT) $(DL_DIR)/$(MTD_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
+       rm -rf $(MTD_DIR)
        mv $(BUILD_DIR)/$(MTD_NAME) $(MTD_DIR)
        toolchain/patch-kernel.sh $(MTD_DIR) package/mtd/mtd-utils.git mtd-utils-all\*.patch
        toolchain/patch-kernel.sh $(MTD_DIR) package/mtd/mtd-utils.git mtd-utils-target\*.patch
@@ -108,7 +108,7 @@ MTD_BUILD_TARGETS := $(addprefix $(MTD_DIR)/, $(MTD_TARGETS_y)) $(addprefix $(MT
 
 $(MTD_BUILD_TARGETS): $(MTD_DIR)/.unpacked
        mkdir -p $(TARGET_DIR)/usr/sbin
-       $(MAKE) OPTFLAGS="-DNEED_BCOPY -Dbcmp=memcmp -I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
+       $(MAKE1) OPTFLAGS="-DNEED_BCOPY -Dbcmp=memcmp -I$(STAGING_DIR)/usr/include $(TARGET_CFLAGS)" \
               BUILDDIR=$(MTD_DIR) \
               CROSS=$(TARGET_CROSS) CC=$(TARGET_CC) WITHOUT_XATTR=1 -C $(MTD_DIR)