qt: use configure option instead a sed hack to disable xinerama
authorMichael Roth <mroth@nessie.de>
Wed, 7 Oct 2009 09:20:36 +0000 (11:20 +0200)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 9 Oct 2009 12:48:24 +0000 (14:48 +0200)
The Qt configure script gained the option '-no-xinerama' in the
meantime. So use it instead hacking the script itself using sed.

Signed-off-by: Michael Roth <mroth@nessie.de>
Acked-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/qt.mk

index 015312e1dae0820f357507547fb11bb65656f952..a4ca3a9a147040d6ac31c1d059512608d3083316 100644 (file)
@@ -406,7 +406,6 @@ ifneq ($(BR2_INET_IPV6),y)
        $(SED) 's/^CFG_IPV6=auto/CFG_IPV6=no/' $(QT_TARGET_DIR)/configure
        $(SED) 's/^CFG_IPV6IFNAME=auto/CFG_IPV6IFNAME=no/' $(QT_TARGET_DIR)/configure
 endif
-       $(SED) 's/^CFG_XINERAMA=auto/CFG_XINERAMA=no/' $(QT_TARGET_DIR)/configure
        # Fix compiler path
        $(call QT_QMAKE_SET,CC,$(TARGET_CC))
        $(call QT_QMAKE_SET,CXX,$(TARGET_CXX))
@@ -433,6 +432,7 @@ endif
                -embedded $(BR2_PACKAGE_QT_EMB_PLATFORM) \
                $(QT_QCONFIG_COMMAND) \
                $(QT_CONFIGURE) \
+               -no-xinerama \
                -no-cups \
                -no-nis \
                -no-accessibility \