package/ghostscript: add cups support
authorAlexey Lukyanchuk <skif@skif-web.ru>
Fri, 1 May 2020 15:49:50 +0000 (18:49 +0300)
committerYann E. MORIN <yann.morin.1998@free.fr>
Fri, 1 May 2020 19:45:56 +0000 (21:45 +0200)
Allow ghostscript to be used by cups for printing.

Signed-off-by: Alexey Lukyanchuk <skif@skif-web.ru>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/ghostscript/ghostscript.mk

index 1d6f8d04a0b937c1c3c92f439e0b09d26ec41d30..7d12195f17827c1d4e347fa69e0e664ad3270f3b 100644 (file)
@@ -39,7 +39,6 @@ GHOSTSCRIPT_CONF_ENV = \
 
 GHOSTSCRIPT_CONF_OPTS = \
        --disable-compile-inits \
-       --disable-cups \
        --enable-fontconfig \
        --with-fontpath=/usr/share/fonts \
        --enable-freetype \
@@ -68,6 +67,15 @@ else
 GHOSTSCRIPT_CONF_OPTS += --disable-openjpeg
 endif
 
+ifeq ($(BR2_PACKAGE_CUPS),y)
+GHOSTSCRIPT_DEPENDENCIES += cups
+GHOSTSCRIPT_CONF_OPTS  += \
+       CUPSCONFIG=$(STAGING_DIR)/usr/bin/cups-config \
+       --enable-cups
+else
+GHOSTSCRIPT_CONF_OPTS += --disable-cups
+endif
+
 ifeq ($(BR2_PACKAGE_XLIB_LIBX11),y)
 GHOSTSCRIPT_DEPENDENCIES += xlib_libX11
 GHOSTSCRIPT_CONF_OPTS += --with-x