package/freescale-imx/firmware-imx: fix sdma/vpu firmware install path
authorStephane Viau <stephane.viau@oss.nxp.com>
Fri, 10 Jul 2020 12:00:43 +0000 (14:00 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sat, 11 Jul 2020 14:11:24 +0000 (16:11 +0200)
In a patch set that did not get in for other reasons, Sebastien proposed
to fix the install path directory of the sdma and vpu firmware code [1]:

"Mainline and NXP kernels expect the sdma firmware to be in
/lib/firmware/imx/sdma so fix the install path [...]"

By looking at the code, I believe this is correct even though I have no
means to test it.

[1] http://lists.busybox.net/pipermail/buildroot/2020-June/284875.html

Suggested-by: Sébastien Szymanski <sebastien.szymanski at armadeus.com>
Signed-off-by: Stephane Viau <stephane.viau@oss.nxp.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/freescale-imx/firmware-imx/firmware-imx.mk

index 6beacc09132ae43f76a9c2a12a8f1b347a50a77a..beaf6ef7792d79abc53386fae86a27018a50f095 100644 (file)
@@ -95,7 +95,7 @@ else
 define FIRMWARE_IMX_INSTALL_TARGET_CMDS
        mkdir -p $(TARGET_DIR)/lib/firmware/imx
        for blobdir in $(FIRMWARE_IMX_BLOBS); do \
-               cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware; \
+               cp -r $(@D)/firmware/$${blobdir} $(TARGET_DIR)/lib/firmware/imx; \
        done
        cp -r $(@D)/firmware/epdc $(TARGET_DIR)/lib/firmware/imx
        mv $(TARGET_DIR)/lib/firmware/imx/epdc/epdc_ED060XH2C1.fw.nonrestricted \