boost: fix sparc64 compile, set the correct instruction-set
authorWaldemar Brodkorb <wbx@openadk.org>
Tue, 3 Nov 2015 21:03:14 +0000 (22:03 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Nov 2015 14:02:08 +0000 (15:02 +0100)
The default for sparc is v7, which doesn't work for sparc64.
Use ultrasparc for sparc64.
Fixes following autobuild errors:
http://autobuild.buildroot.net/results/0cad0a6eddc153098bb6d1501afd1cf4a57a82d1/

Signed-off-by: Waldemar Brodkorb <wbx@openadk.org>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/boost/boost.mk

index 80325b0a4e2fd9225d9450f2ec9d0d29ffa5b0cb..d91baf117505da35660677fd09a3bddd89671a01 100644 (file)
@@ -89,6 +89,10 @@ BOOST_OPTS += toolset=gcc \
             abi=$(BOOST_ABI) \
             variant=$(if $(BR2_ENABLE_DEBUG),debug,release)
 
+ifeq ($(BR2_sparc64),y)
+BOOST_OPTS += architecture=sparc instruction-set=ultrasparc
+endif
+
 # By default, Boost build and installs both the shared and static
 # variants. Override that if we want static only or shared only.
 ifeq ($(BR2_STATIC_LIBS),y)