wine: Add openldap dependency check
authorAndré Hentschel <nerv@dawncrow.de>
Sun, 8 Mar 2015 14:22:11 +0000 (15:22 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 8 Mar 2015 17:48:04 +0000 (18:48 +0100)
Signed-off-by: André Hentschel <nerv@dawncrow.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/wine/wine.mk

index e931c877e65081c346329117f1268125c58b0595..571606de01df9ef754f8cd41df9f3e354f95da26 100644 (file)
@@ -23,7 +23,6 @@ WINE_CONF_OPTS = \
        --without-gphoto \
        --without-gsm \
        --without-hal \
-       --without-ldap \
        --without-netapi \
        --without-openal \
        --without-opencl \
@@ -160,6 +159,13 @@ else
 WINE_CONF_OPTS += --without-curses
 endif
 
+ifeq ($(BR2_PACKAGE_OPENLDAP),y)
+WINE_CONF_OPTS += --with-ldap
+WINE_DEPENDENCIES += openldap
+else
+WINE_CONF_OPTS += --without-ldap
+endif
+
 ifeq ($(BR2_PACKAGE_SANE_BACKENDS),y)
 WINE_CONF_OPTS += --with-sane
 WINE_DEPENDENCIES += sane-backends