libcgicc: bump to version 3.2.12
authorGustavo Zacarias <gustavo@zacarias.com.ar>
Wed, 1 Jan 2014 13:58:47 +0000 (10:58 -0300)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 1 Jan 2014 17:16:28 +0000 (18:16 +0100)
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libcgicc/libcgicc-01-disable-documentation-option.patch [new file with mode: 0644]
package/libcgicc/libcgicc-3.2.9-disable-documentation-option.patch [deleted file]
package/libcgicc/libcgicc.mk

diff --git a/package/libcgicc/libcgicc-01-disable-documentation-option.patch b/package/libcgicc/libcgicc-01-disable-documentation-option.patch
new file mode 100644 (file)
index 0000000..a7b04a8
--- /dev/null
@@ -0,0 +1,50 @@
+Index: cgicc-3.2.9/Makefile.am
+===================================================================
+--- cgicc-3.2.9.orig/Makefile.am       2010-02-25 16:34:06.000000000 +0100
++++ cgicc-3.2.9/Makefile.am    2010-02-25 16:34:14.000000000 +0100
+@@ -8,9 +8,15 @@
+ DEMO =
+ endif
++if DOC
++DOCDIR = doc
++else
++DOC =
++endif
++
+ ACLOCAL_AMFLAGS= 
+-SUBDIRS = cgicc doc support $(DEMO)
++SUBDIRS = cgicc $(DOCDIR) support $(DEMO)
+ CLEANFILES = *~
+Index: cgicc-3.2.9/configure.ac
+===================================================================
+--- cgicc-3.2.9.orig/configure.ac      2010-02-25 16:34:06.000000000 +0100
++++ cgicc-3.2.9/configure.ac   2010-02-25 16:45:46.000000000 +0100
+@@ -17,9 +17,23 @@
+ AC_PROG_CXX
+ AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
+-AC_CHECK_PROG(DOXYGEN, doxygen, doxygen, /bin/echo)
++AC_ARG_ENABLE(doc, 
++  [  --enable-doc          build doc [[default=yes]]],
++  [case "${enableval}" in
++    yes) cgicc_doc=yes ;;
++    no)  cgicc_doc=no ;;
++    *) AC_MSG_ERROR(bad value ${enableval} for --enable-doc) ;;
++  esac], cgicc_doc=yes)
++
++if test "$cgicc_doc" = yes; then
++ AC_CHECK_PROG(DOXYGEN, doxygen, doxygen)
++ if test -z "$DOXYGEN" ; then
++   AC_MSG_ERROR([Doxygen is required to build the documentation])
++ fi
++fi
++AM_CONDITIONAL(DOC, test "$cgicc_doc" = yes)
+ dnl Determine host system type
diff --git a/package/libcgicc/libcgicc-3.2.9-disable-documentation-option.patch b/package/libcgicc/libcgicc-3.2.9-disable-documentation-option.patch
deleted file mode 100644 (file)
index a7b04a8..0000000
+++ /dev/null
@@ -1,50 +0,0 @@
-Index: cgicc-3.2.9/Makefile.am
-===================================================================
---- cgicc-3.2.9.orig/Makefile.am       2010-02-25 16:34:06.000000000 +0100
-+++ cgicc-3.2.9/Makefile.am    2010-02-25 16:34:14.000000000 +0100
-@@ -8,9 +8,15 @@
- DEMO =
- endif
-+if DOC
-+DOCDIR = doc
-+else
-+DOC =
-+endif
-+
- ACLOCAL_AMFLAGS= 
--SUBDIRS = cgicc doc support $(DEMO)
-+SUBDIRS = cgicc $(DOCDIR) support $(DEMO)
- CLEANFILES = *~
-Index: cgicc-3.2.9/configure.ac
-===================================================================
---- cgicc-3.2.9.orig/configure.ac      2010-02-25 16:34:06.000000000 +0100
-+++ cgicc-3.2.9/configure.ac   2010-02-25 16:45:46.000000000 +0100
-@@ -17,9 +17,23 @@
- AC_PROG_CXX
- AC_PROG_INSTALL
- AC_PROG_LIBTOOL
--AC_CHECK_PROG(DOXYGEN, doxygen, doxygen, /bin/echo)
-+AC_ARG_ENABLE(doc, 
-+  [  --enable-doc          build doc [[default=yes]]],
-+  [case "${enableval}" in
-+    yes) cgicc_doc=yes ;;
-+    no)  cgicc_doc=no ;;
-+    *) AC_MSG_ERROR(bad value ${enableval} for --enable-doc) ;;
-+  esac], cgicc_doc=yes)
-+
-+if test "$cgicc_doc" = yes; then
-+ AC_CHECK_PROG(DOXYGEN, doxygen, doxygen)
-+ if test -z "$DOXYGEN" ; then
-+   AC_MSG_ERROR([Doxygen is required to build the documentation])
-+ fi
-+fi
-+AM_CONDITIONAL(DOC, test "$cgicc_doc" = yes)
- dnl Determine host system type
index a3c64d26f82e7970eeedf43706d3ff973cee1018..f1c181f3825c00d82815be0f53f6cab5708a979c 100644 (file)
@@ -4,7 +4,7 @@
 #
 ################################################################################
 
-LIBCGICC_VERSION = 3.2.9
+LIBCGICC_VERSION = 3.2.12
 LIBCGICC_SITE = $(BR2_GNU_MIRROR)/cgicc
 LIBCGICC_SOURCE = cgicc-$(LIBCGICC_VERSION).tar.gz
 LIBCGICC_LICENSE = LGPLv3+