package/poppler: fix build with cmake < 3.10
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sun, 2 Jun 2019 19:19:22 +0000 (21:19 +0200)
committerArnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Sat, 8 Jun 2019 19:35:46 +0000 (21:35 +0200)
poppler requires threads, and our compiler always accepts the -pthread
argument, so THREADS_HAVE_PTHREAD_ARG can safely be set to ON.

Fixes:
 - http://autobuild.buildroot.org/results/f9e24d38d3aa4519615c5a0ae7f62af610df976f

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Arnout: set THREADS_HAVE_PTHREAD_ARG instead of THREADS_PTHREAD_ARG,
and set it to ON instead of OFF because we always have threads.]
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
package/poppler/poppler.mk

index a2bb7e30498c093abcdb0c9947e53ee2b295926e..37566504e9e9ee6d64390a786da101cde8600bed 100644 (file)
@@ -20,6 +20,9 @@ POPPLER_CONF_OPTS = \
        -DENABLE_GOBJECT_INTROSPECTION=OFF \
        -DENABLE_GTK_DOC=OFF
 
+# cmake older than 3.10 requires this to avoid try_run() in FindThreads
+POPPLER_CONF_OPTS += -DTHREADS_HAVE_PTHREAD_ARG=ON
+
 ifeq ($(BR2_TOOLCHAIN_HAS_LIBATOMIC),y)
 POPPLER_CONF_OPTS += -DCMAKE_CXX_FLAGS="$(TARGET_CXXFLAGS) -latomic"
 endif