read-edid: bump version to 3.0.2
authorPeter Seiderer <ps.report@gmx.net>
Mon, 7 Dec 2015 20:33:09 +0000 (21:33 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 9 Dec 2015 08:41:45 +0000 (09:41 +0100)
- update hash
- change from autotools to cmake package
- update license info
- enable get-edid command (i2c build)
- add patch fixing install error because of missing file COPYING

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Reviewed-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Tested-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/read-edid/0001-Fix-install-file-list.patch [new file with mode: 0644]
package/read-edid/Config.in
package/read-edid/read-edid.hash
package/read-edid/read-edid.mk

diff --git a/package/read-edid/0001-Fix-install-file-list.patch b/package/read-edid/0001-Fix-install-file-list.patch
new file mode 100644 (file)
index 0000000..622e97d
--- /dev/null
@@ -0,0 +1,29 @@
+From 562f48bee3443bda0ac257f2b0c52a72208163e0 Mon Sep 17 00:00:00 2001
+From: Peter Seiderer <ps.report@gmx.net>
+Date: Mon, 7 Dec 2015 21:20:38 +0100
+Subject: [PATCH] Fix install file list.
+
+Fixes:
+  CMake Error at cmake_install.cmake:40 (file):
+    file INSTALL cannot find
+    ".../build/read-edid-3.0.2/COPYING".
+
+Signed-off-by: Peter Seiderer <ps.report@gmx.net>
+---
+ CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 7bf4561..2b9bc86 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -13,5 +13,5 @@ endif ()
+ add_subdirectory (parse-edid)
+ INSTALL(FILES get-edid.1 DESTINATION share/man/man1)
+-INSTALL(FILES AUTHORS ChangeLog COPYING README DESTINATION
++INSTALL(FILES AUTHORS ChangeLog README DESTINATION
+       share/doc/read-edid)
+-- 
+2.1.4
+
index a4668e684c95bd81e71c3d41e0a351155df550b3..c830e17f1f536b390afd43931887cf61c4b87e4c 100644 (file)
@@ -10,6 +10,4 @@ config BR2_PACKAGE_READ_EDID
          which turns the raw binary information into an
          XF86Config-compatible monitor section.
 
-         Notice that the get-edid tool is only available on x86.
-
          http://polypux.org/projects/read-edid/
index 2c5501cee1cd647d45818d02942f876c3e17e2e9..30052171e130aea5b1373b8a7f58066f40c079f6 100644 (file)
@@ -1,2 +1,2 @@
 # Locally calculated
-sha256 c1b5d839fe6349efc183b3a3d33a8be1cd0dfea3c94015a86159d8aaeb6e9dd7        read-edid-1.4.2.tar.gz
+sha256 c7c6d8440f5b90f98e276829271ccea5b2ff5a3413df8a0f87ec09f834af186f read-edid-3.0.2.tar.gz
index f047e79b8dd0db6acf8811f2ffb7fb7a048f1671..3e38f503fd358866462245d02980a7e2499d4a97 100644 (file)
@@ -4,13 +4,12 @@
 #
 ################################################################################
 
-READ_EDID_VERSION = 1.4.2
+READ_EDID_VERSION = 3.0.2
 READ_EDID_SITE = http://www.polypux.org/projects/read-edid
-READ_EDID_LICENSE = GPLv2
-READ_EDID_LICENSE_FILES = COPYING
+READ_EDID_LICENSE = BSD-like
+READ_EDID_LICENSE_FILES = LICENSE
 
-define READ_EDID_BUILD_CMDS
-       $(MAKE) $(TARGET_CONFIGURE_OPTS) -C $(@D)
-endef
+# disable classic get-edid support (needs libx86)
+READ_EDID_CONF_OPTS += -DCLASSICBUILD=OFF
 
-$(eval $(autotools-package))
+$(eval $(cmake-package))