pkg-python: use the newly defined PYTHON_PATH variable
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 13 Feb 2014 20:48:51 +0000 (21:48 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 14 Feb 2014 20:40:38 +0000 (21:40 +0100)
Now that the Python package exposes its PYTHON_PATH variable, we can
use it in the package infrastructure. This prepares both the upcoming
bump of Python 2.x, and the introduction of Python 3 support in the
Python package infrastructure.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/pkg-python.mk

index f33980aaed2374208ad59cff8a1ea19b160d00cd..65c9b4adc38f5c3235a69bce0f6d0b5e66333619 100644 (file)
@@ -48,7 +48,7 @@ HOST_PKG_PYTHON_DISTUTILS_INSTALL_OPT = \
 # Target setuptools-based packages
 PKG_PYTHON_SETUPTOOLS_ENV = \
        PATH="$(TARGET_PATH)" \
-       PYTHONPATH="$(TARGET_DIR)/usr/lib/python$(PYTHON_VERSION_MAJOR)/site-packages" \
+       PYTHONPATH="$(PYTHON_PATH)" \
        PYTHONXCPREFIX="$(STAGING_DIR)/usr/" \
        CROSS_COMPILING=yes \
        _python_sysroot=$(STAGING_DIR) \