package/gdb: don't remove support files if python chosen
authorJonas Zaddach <jzaddach@sourcefire.com>
Tue, 10 Apr 2018 19:37:22 +0000 (12:37 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 27 Apr 2018 21:09:17 +0000 (23:09 +0200)
If one wants to use GDB with python support on the target, you need the support
files installed by GDB. These get usually deleted to save some space, so I just
wrapped the Makefile code deleting them in a conditional block depending on if
python support is active or not.

Signed-off-by: Jonas Zaddach <jzaddach@cisco.com>
Reviewed-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
[Thomas:
 - use positive logic "if python is disabled"
 - put the comment inside the condition, as suggested by Arnout]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/gdb/gdb.mk

index ca71349cb322ea9c1aab918b68f863b76985820d..215f473cc01ec188d7ef3184ce6e1d375ea35edd 100644 (file)
@@ -164,6 +164,7 @@ else
 GDB_CONF_OPTS += --without-zlib
 endif
 
+ifeq ($(BR2_PACKAGE_GDB_PYTHON),)
 # This removes some unneeded Python scripts and XML target description
 # files that are not useful for a normal usage of the debugger.
 define GDB_REMOVE_UNNEEDED_FILES
@@ -171,6 +172,7 @@ define GDB_REMOVE_UNNEEDED_FILES
 endef
 
 GDB_POST_INSTALL_TARGET_HOOKS += GDB_REMOVE_UNNEEDED_FILES
+endif
 
 # This installs the gdbserver somewhere into the $(HOST_DIR) so that
 # it becomes an integral part of the SDK, if the toolchain generated