liblo: new pachage
authorStephan Hoffmann <sho@relinux.de>
Wed, 29 Aug 2012 09:01:07 +0000 (11:01 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Thu, 30 Aug 2012 03:09:11 +0000 (05:09 +0200)
liblo is an implementation of the Open Sound Control protocol
for POSIX systems.

http://liblo.sourceforge.net/

[thomas.petazzoni@free-electrons.com: add dependency on thread support
in toolchain]

Signed-off-by: Stephan Hoffmann <sho@relinux.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/liblo/Config.in [new file with mode: 0644]
package/liblo/liblo.mk [new file with mode: 0644]

index f0fe0a68146aa887bdf3840fe5fc6bf38bd837a8..5b4788fbf891a22c41084b260ed68fbdb392df59 100644 (file)
@@ -295,6 +295,7 @@ source "package/libcdaudio/Config.in"
 source "package/libcue/Config.in"
 source "package/libcuefile/Config.in"
 source "package/libid3tag/Config.in"
+source "package/liblo/Config.in"
 source "package/libmad/Config.in"
 source "package/libmpd/Config.in"
 source "package/libreplaygain/Config.in"
diff --git a/package/liblo/Config.in b/package/liblo/Config.in
new file mode 100644 (file)
index 0000000..4c2d719
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_LIBLO
+       bool "liblo"
+       depends on BR2_TOOLCHAIN_HAS_THREADS
+       help
+         liblo is an implementation of the Open Sound Control
+         protocol for POSIX systems
+
+         http://liblo.sourceforge.net/
+
+comment "liblo requires thread support in toolchain"
+       depends on !BR2_TOOLCHAIN_HAS_THREADS
diff --git a/package/liblo/liblo.mk b/package/liblo/liblo.mk
new file mode 100644 (file)
index 0000000..924c3a7
--- /dev/null
@@ -0,0 +1,14 @@
+#############################################################
+#
+# liblo
+#
+#############################################################
+LIBLO_VERSION = 0.26
+LIBLO_SOURCE = liblo-$(LIBLO_VERSION).tar.gz
+LIBLO_SITE = http://downloads.sourceforge.net/project/liblo/liblo/$(LIBLO_VERSION)
+
+LIBLO_LICENSE = LGPLv2.1+
+LIBLO_LICENSE_FILES = COPYING
+LIBLO_INSTALL_STAGING = YES
+
+$(eval $(autotools-package))