package/apparmor: add option to install binutils
authorAngelo Compagnucci <angelo@amarulasolutions.com>
Fri, 27 Mar 2020 21:13:14 +0000 (22:13 +0100)
committerYann E. MORIN <yann.morin.1998@free.fr>
Mon, 20 Apr 2020 07:53:05 +0000 (09:53 +0200)
Signed-off-by: Angelo Compagnucci <angelo@amarulasolutions.com>
[yann.morin.1998@free.fr: split off to its own patch]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
Tested-by: Angelo Compagnucci <angelo@amarulasolutions.com>
package/apparmor/Config.in
package/apparmor/apparmor.mk

index e2195078035ba99025d592b71a9bd4562399c7df..edc837366dc2bb695d1b2f1c994ef3002e991aa7 100644 (file)
@@ -18,6 +18,16 @@ config BR2_PACKAGE_APPARMOR
 
          http://wiki.apparmor.net
 
+if BR2_PACKAGE_APPARMOR
+
+config BR2_PACKAGE_APPARMOR_BINUTILS
+       bool "binutils"
+       help
+         A set of utilities (written in C):
+           aa-enabled    aa-exec
+
+endif # BR2_PACKAGE_APPARMOR
+
 comment "apparmor needs a toolchain w/ headers >= 3.16, threads, C++"
        depends on BR2_USE_MMU
        depends on BR2_TOOLCHAIN_HAS_SYNC_4
index cab37d06a6df37ec54e518d39f18ce98ee733c93..9ee5304a1643575289d3bbb130bddc05cedbe139 100644 (file)
@@ -17,6 +17,10 @@ APPARMOR_DEPENDENCIES = libapparmor
 APPARMOR_TOOLS = parser
 APPARMOR_MAKE_OPTS = USE_SYSTEM=1
 
+ifeq ($(BR2_PACKAGE_APPARMOR_BINUTILS),y)
+APPARMOR_TOOLS += binutils
+endif
+
 define APPARMOR_BUILD_CMDS
        $(foreach tool,$(APPARMOR_TOOLS),\
                $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) \