setools: depends on host-flex
authorVicente Olivert Riera <Vincent.Riera@imgtec.com>
Wed, 30 Sep 2015 07:46:36 +0000 (08:46 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 30 Sep 2015 08:15:40 +0000 (10:15 +0200)
setools needs host-flex in order to generate some source files during
build time, otherwise it will fail with an error like this one:

error: policy_scan.c: No such file or directory

Issue reported here as a race condition problem, but it turned out that
it the actual problem was the lack of host-flex:

  https://github.com/TresysTechnology/setools3/issues/5#issuecomment-144048612

Fixes:

  http://autobuild.buildroot.net/results/dad/dad9d79c10722b203536540141a6defc79937e4e/

Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/setools/setools.mk

index a2bfd420e515eeb755303dd95bfd0fd98dc0c13c..612ab8978f70a86f3439044cce63dfe0fd75b3f0 100644 (file)
@@ -7,7 +7,7 @@
 SETOOLS_VERSION = 3.3.8
 SETOOLS_SOURCE = setools-$(SETOOLS_VERSION).tar.bz2
 SETOOLS_SITE = https://raw.githubusercontent.com/wiki/TresysTechnology/setools3/files/dists/setools-$(SETOOLS_VERSION)/
-SETOOLS_DEPENDENCIES = libselinux libsepol sqlite libxml2 bzip2 host-bison
+SETOOLS_DEPENDENCIES = libselinux libsepol sqlite libxml2 bzip2 host-bison host-flex
 SETOOLS_INSTALL_STAGING = YES
 SETOOLS_LICENSE = GPLv2+ LGPLv2.1+
 SETOOLS_LICENSE_FILES = COPYING COPYING.GPL COPYING.LGPL