pkg-download: fix svn download for deleted path
authorRyan Barnett <ryan.barnett@rockwellcollins.com>
Thu, 26 Jun 2014 13:17:39 +0000 (08:17 -0500)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 29 Jun 2014 08:42:51 +0000 (10:42 +0200)
If a SVN path has been deleted in a future revision, downloading a
package's source will fail using 'svn checkout -r'. Fix using
URL@REV syntax since the SVN command will then verify the path at the
specified version. Without using the URL@REV syntax, the SVN command
will attempt to verify the path exists on the the HEAD revision before
checking out the path at the specified revision.

Error seen if SVN path has been deleted in HEAD using svn checkout -r:
  svn: E160013: '/svn/path/' path not found

Signed-off-by: Ryan Barnett <ryan.barnett@rockwellcollins.com>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/pkg-download.mk

index 4cfb913b926b1b215f39a765a888309462d7caaa..e07fd1b550fe32be749b742d5c10e6fdf83d5f8c 100644 (file)
@@ -145,14 +145,14 @@ endef
 define DOWNLOAD_SVN
        test -e $(DL_DIR)/$($(PKG)_SOURCE) || \
        (pushd $(DL_DIR) > /dev/null && \
-       $(SVN) export -r $($(PKG)_DL_VERSION) $($(PKG)_SITE) $($(PKG)_DL_DIR) && \
+       $(SVN) export $($(PKG)_SITE)@$($(PKG)_DL_VERSION) $($(PKG)_DL_DIR) && \
        $(TAR) czf $($(PKG)_SOURCE) $($(PKG)_BASE_NAME)/ && \
        rm -rf $($(PKG)_DL_DIR) && \
        popd > /dev/null)
 endef
 
 define SOURCE_CHECK_SVN
-  $(SVN) ls $($(PKG)_SITE) > /dev/null
+  $(SVN) ls $($(PKG)_SITE)@$($(PKG)_DL_VERSION) > /dev/null
 endef
 
 define SHOW_EXTERNAL_DEPS_SVN