package: use SPDX short identifier for AFLv2.1
authorRahul Bedarkar <rahulbedarkar89@gmail.com>
Thu, 30 Mar 2017 13:43:45 +0000 (19:13 +0530)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 1 Apr 2017 13:34:43 +0000 (15:34 +0200)
We want to use SPDX identifier for license string as much as possible.
SPDX short identifier for AFLv2.1 is AFL-2.1.

This change is done using following command.
find . -name "*.mk" | xargs sed -ri '/LICENSE( )?[\+:]?=/s/AFLv2.1(\+)?/AFL-2.1\1/g'

Signed-off-by: Rahul Bedarkar <rahulbedarkar89@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/dbus-glib/dbus-glib.mk
package/dbus/dbus.mk

index e14a095912d5b77edef33f451746fb0255accf8f..22dcdb15fe9f921e650d57771e79fb3c4ea6743a 100644 (file)
@@ -7,7 +7,7 @@
 DBUS_GLIB_VERSION = 0.108
 DBUS_GLIB_SITE = http://dbus.freedesktop.org/releases/dbus-glib
 DBUS_GLIB_INSTALL_STAGING = YES
-DBUS_GLIB_LICENSE = AFLv2.1 or GPL-2.0+
+DBUS_GLIB_LICENSE = AFL-2.1 or GPL-2.0+
 DBUS_GLIB_LICENSE_FILES = COPYING
 
 DBUS_GLIB_CONF_ENV = \
index ee8ffe11ae8395b02e511a39a3099b0564e6a737..52c1912e073b562238bcc1a9e5c17c20fc5a71a1 100644 (file)
@@ -6,7 +6,7 @@
 
 DBUS_VERSION = 1.10.16
 DBUS_SITE = http://dbus.freedesktop.org/releases/dbus
-DBUS_LICENSE = AFLv2.1 or GPL-2.0+ (library, tools), GPL-2.0+ (tools)
+DBUS_LICENSE = AFL-2.1 or GPL-2.0+ (library, tools), GPL-2.0+ (tools)
 DBUS_LICENSE_FILES = COPYING
 DBUS_INSTALL_STAGING = YES