package/python-argon2-cffi: new package
authorJames Hilliard <james.hilliard1@gmail.com>
Thu, 13 Feb 2020 07:42:45 +0000 (00:42 -0700)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Sun, 12 Apr 2020 19:39:45 +0000 (21:39 +0200)
The secure Argon2 password hashing algorithm.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/python-argon2-cffi/Config.in [new file with mode: 0644]
package/python-argon2-cffi/python-argon2-cffi.hash [new file with mode: 0644]
package/python-argon2-cffi/python-argon2-cffi.mk [new file with mode: 0644]

index aae94314cfacb61d75df82128c732e0600eded46..c17d92ed4ba26374b10871e63f15586fdc5a9a36 100644 (file)
@@ -1189,6 +1189,7 @@ F:        package/python-aiojobs/
 F:     package/python-aiorwlock/
 F:     package/python-aiosignal/
 F:     package/python-aiozipkin/
+F:     package/python-argon2-cffi/
 F:     package/python-async-lru/
 F:     package/python-async-timeout/
 F:     package/python-brotli/
index f7d70a1afddbc51898efdd11fdc24c39f2508400..7c9575c8b7346376081e24e2178879dc288592f6 100644 (file)
@@ -868,6 +868,7 @@ menu "External python modules"
        source "package/python-aiozipkin/Config.in"
        source "package/python-alsaaudio/Config.in"
        source "package/python-argh/Config.in"
+       source "package/python-argon2-cffi/Config.in"
        source "package/python-arrow/Config.in"
        source "package/python-asgiref/Config.in"
        source "package/python-asn1crypto/Config.in"
diff --git a/package/python-argon2-cffi/Config.in b/package/python-argon2-cffi/Config.in
new file mode 100644 (file)
index 0000000..c1adcbc
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_ARGON2_CFFI
+       bool "python-argon2-cffi"
+       select BR2_PACKAGE_PYTHON_CFFI # runtime
+       select BR2_PACKAGE_PYTHON_ENUM34 if BR2_PACKAGE_PYTHON # runtime
+       select BR2_PACKAGE_PYTHON_SIX # runtime
+       help
+         The secure Argon2 password hashing algorithm.
+
+         https://argon2-cffi.readthedocs.io/
diff --git a/package/python-argon2-cffi/python-argon2-cffi.hash b/package/python-argon2-cffi/python-argon2-cffi.hash
new file mode 100644 (file)
index 0000000..631c85a
--- /dev/null
@@ -0,0 +1,5 @@
+# md5, sha256 from https://pypi.org/pypi/argon2_cffi/json
+md5    3fb9154af6f7a113028a7a8bc7da715d  argon2-cffi-19.2.0.tar.gz
+sha256 ffaa623eea77b497ffbdd1a51e941b33d3bf552c60f14dbee274c4070677bda3  argon2-cffi-19.2.0.tar.gz
+# Locally computed sha256 checksums
+sha256 bf659a28b49240602f56bbdf490cbe2ec509b15b98f99d7b19a52c740e327863  LICENSE
diff --git a/package/python-argon2-cffi/python-argon2-cffi.mk b/package/python-argon2-cffi/python-argon2-cffi.mk
new file mode 100644 (file)
index 0000000..099574e
--- /dev/null
@@ -0,0 +1,15 @@
+################################################################################
+#
+# python-argon2-cffi
+#
+################################################################################
+
+PYTHON_ARGON2_CFFI_VERSION = 19.2.0
+PYTHON_ARGON2_CFFI_SOURCE = argon2-cffi-$(PYTHON_ARGON2_CFFI_VERSION).tar.gz
+PYTHON_ARGON2_CFFI_SITE = https://files.pythonhosted.org/packages/e4/96/f1bf2369f29794971f836b8eff5e3bdb653043f1b61d104eae21b1de3ccb
+PYTHON_ARGON2_CFFI_SETUP_TYPE = setuptools
+PYTHON_ARGON2_CFFI_LICENSE = MIT
+PYTHON_ARGON2_CFFI_LICENSE_FILES = LICENSE
+PYTHON_ARGON2_CFFI_DEPENDENCIES = host-python-cffi
+
+$(eval $(python-package))