qt: add option to hide mouse cursor
authorDaniel Nyström <daniel.nystrom@timeterminal.se>
Wed, 2 Feb 2011 23:06:44 +0000 (00:06 +0100)
committerPeter Korsgaard <jacmet@sunsite.dk>
Fri, 25 Feb 2011 20:45:31 +0000 (21:45 +0100)
Allow the user to build Qt with the QT_NO_QWS_CURSOR macro set.

Signed-off-by: Daniel Nyström <daniel.nystrom@timeterminal.se>
Acked-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/qt/Config.mouse.in
package/qt/qt.mk

index 87973d2fe2acc4209d5feb928a26142f731b949c..16c41c18f6244bd10679d070ff1a512bed5319f1 100644 (file)
@@ -15,4 +15,11 @@ config BR2_PACKAGE_QT_MOUSE_TSLIB
 config BR2_PACKAGE_QT_MOUSE_QVFB
        bool "qvfb"
 
+comment "Mouse Options"
+
+config BR2_PACKAGE_QT_MOUSE_NO_QWS_CURSOR
+       bool "Hide the mouse cursor"
+       help
+         Do not show the mouse cursor in QWS.
+
 endmenu
index 3dfdcbf0b2e49580e6ab15f36f7da0f6d0975a3c..cc90190df74ea1611f3de36c7106db2ea2ffdc47 100644 (file)
@@ -154,6 +154,9 @@ QT_CONFIGURE += -qt-mouse-qvfb
 else
 QT_CONFIGURE += -no-mouse-qvfb
 endif
+ifeq ($(BR2_PACKAGE_QT_MOUSE_NO_QWS_CURSOR),y)
+QT_CONFIGURE+= -D QT_NO_QWS_CURSOR
+endif
 
 ### Keyboard drivers
 ifeq ($(BR2_PACKAGE_QT_KEYBOARD_TTY),y)