package/openvmtools: add resolutionkms option
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Sat, 16 Feb 2019 18:20:48 +0000 (19:20 +0100)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Wed, 27 Mar 2019 18:46:26 +0000 (19:46 +0100)
resolutionkms has been added in version 10.2.5 and
https://github.com/vmware/open-vm-tools/commit/dc95efcb7d4bb7d865b7d37f9aaafe6fb8009e59

It depends on udev and libdrm's vmwgfx option

Fixes:
 - http://autobuild.buildroot.org/results/92f7c88917066b1d3e15ee0d1baafe01c0cb29c8

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/openvmtools/Config.in
package/openvmtools/openvmtools.mk

index 72c0293de7250d22a8c58241abee4f7750067def..97860f8c6f57bf7e00a4e8ef1fb24b4d2b9e505b 100644 (file)
@@ -45,6 +45,20 @@ config BR2_PACKAGE_OPENVMTOOLS_PAM
 comment "PAM support needs a glibc toolchain w/ dynamic library"
        depends on BR2_STATIC_LIBS || BR2_TOOLCHAIN_USES_MUSL
 
+config BR2_PACKAGE_OPENVMTOOLS_RESOLUTIONKMS
+       bool "resolutionkms support"
+       depends on BR2_PACKAGE_HAS_UDEV
+       depends on BR2_TOOLCHAIN_HAS_THREADS # libdrm
+       depends on BR2_i386 || BR2_x86_64 # libdrm vmwgfx
+       select BR2_PACKAGE_LIBDRM
+       select BR2_PACKAGE_LIBDRM_VMWGFX
+       help
+         Enable support for resolutionkms
+
+comment "resolutionkms needs udev, a toolchain w/ threads"
+       depends on BR2_i386 || BR2_x86_64
+       depends on !BR2_PACKAGE_HAS_UDEV || !BR2_TOOLCHAIN_HAS_THREADS
+
 endif
 
 comment "openvmtools needs a glibc or musl toolchain w/ wchar, threads, RPC, locale"
index 0dc2956d02589508b3887d65959179304d85689e..145ee618956521a5b4ebc23f3c93115c7947b3df 100644 (file)
@@ -47,6 +47,13 @@ else
 OPENVMTOOLS_CONF_OPTS += --without-pam
 endif
 
+ifeq ($(BR2_PACKAGE_OPENVMTOOLS_RESOLUTIONKMS),y)
+OPENVMTOOLS_CONF_OPTS += --enable-resolutionkms
+OPENVMTOOLS_DEPENDENCIES += libdrm udev
+else
+OPENVMTOOLS_CONF_OPTS += --disable-resolutionkms
+endif
+
 # symlink needed by lib/system/systemLinux.c (or will cry in /var/log/messages)
 # defined in lib/misc/hostinfoPosix.c
 # /sbin/shutdown needed for Guest OS restart/shutdown from hypervisor