iproute2: add dependency on host-bison
authorThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sat, 23 Mar 2013 22:26:36 +0000 (22:26 +0000)
committerPeter Korsgaard <jacmet@sunsite.dk>
Sun, 24 Mar 2013 12:44:32 +0000 (13:44 +0100)
iproute2 requires bison, so we add the necessary dependency. In
addition, in order for iproute2 to find bison, we need to pass
$(TARGET_MAKE_ENV).

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
package/iproute2/iproute2.mk

index 7766ab8703ad64a7cebaf67f05df1d760058c7d7..98a7da07842492b6f2bb38108922a37035588a1f 100644 (file)
@@ -10,6 +10,8 @@ IPROUTE2_TARGET_SBINS = ctstat genl ifstat ip lnstat nstat routef routel rtacct
 IPROUTE2_LICENSE = GPLv2
 IPROUTE2_LICENSE_FILES = COPYING
 
+IPROUTE2_DEPENDENCIES += host-bison
+
 # If both iproute2 and busybox are selected, make certain we win
 # the fight over who gets to have their utils actually installed.
 ifeq ($(BR2_PACKAGE_BUSYBOX),y)
@@ -42,11 +44,12 @@ endef
 
 define IPROUTE2_BUILD_CMDS
        $(SED) 's/$$(CCOPTS)//' $(@D)/netem/Makefile
-       $(MAKE) CC="$(TARGET_CC)" CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" -C $(@D)
+       $(TARGET_MAKE_ENV) $(MAKE) CC="$(TARGET_CC)" CCOPTS="$(TARGET_CFLAGS) -D_GNU_SOURCE" -C $(@D)
 endef
 
 define IPROUTE2_INSTALL_TARGET_CMDS
-       $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" SBINDIR=/sbin \
+       $(TARGET_MAKE_ENV) $(MAKE) -C $(@D) DESTDIR="$(TARGET_DIR)" \
+               SBINDIR=/sbin \
                DOCDIR=/usr/share/doc/iproute2-$(IPROUTE2_VERSION) \
                MANDIR=/usr/share/man install
        # Wants bash