- account for now optional archive
authorBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 25 Jun 2007 16:56:11 +0000 (16:56 -0000)
committerBernhard Reutner-Fischer <rep.dot.nop@gmail.com>
Mon, 25 Jun 2007 16:56:11 +0000 (16:56 -0000)
package/ncurses/ncurses.mk

index 0e5849d79df1d28e41c8da9491e1b50a36efa1a7..cf2f077a20406fa4165d7a7abbcae6699a470c17 100644 (file)
@@ -83,7 +83,7 @@ $(NCURSES_DIR)/lib/libncurses.so.$(NCURSES_VER): $(NCURSES_DIR)/.configured
        $(MAKE1) DESTDIR=$(STAGING_DIR) -C $(NCURSES_DIR) \
                libs panel menu form headers
 
-$(STAGING_DIR)/usr/lib/libncurses.a: $(NCURSES_DIR)/lib/libncurses.so.$(NCURSES_VER)
+$(STAGING_DIR)/lib/libncurses.so.$(NCURSES_VER): $(NCURSES_DIR)/lib/libncurses.so.$(NCURSES_VER)
        $(MAKE1) \
            prefix=$(STAGING_DIR)/usr/ \
            exec_prefix=$(STAGING_DIR) \
@@ -103,7 +103,7 @@ $(STAGING_DIR)/usr/lib/libncurses.a: $(NCURSES_DIR)/lib/libncurses.so.$(NCURSES_
        chmod a-x $(NCURSES_DIR)/lib/libncurses.so*
        touch -c $@
 
-$(TARGET_DIR)/lib/libncurses.so.$(NCURSES_VER): $(STAGING_DIR)/usr/lib/libncurses.a
+$(TARGET_DIR)/lib/libncurses.so.$(NCURSES_VER): $(STAGING_DIR)/lib/libncurses.so.$(NCURSES_VER)
        cp -dpf $(NCURSES_DIR)/lib/libncurses.so* $(TARGET_DIR)/lib/
        -cp -dpf $(STAGING_DIR)/usr/lib/terminfo $(TARGET_DIR)/usr/lib/
        mkdir -p $(TARGET_DIR)/usr/share/terminfo/x