package/gdb: fix gnulib issue with musl and uClibc toolchains again
authorRomain Naour <romain.naour@gmail.com>
Sat, 11 Mar 2017 21:26:45 +0000 (22:26 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 12 Mar 2017 13:16:38 +0000 (14:16 +0100)
The commit [1] doesn't fix this issue for all cases (it doesn't work
when BR2_PACKAGE_GDB_DEBUGGER=y).
So, leave the configure script alone and override
gl_cv_func_gettimeofday_clobber from GDB_MAKE_ENV.

[1] 560334bb2a46a77081a3944d092df7732dfca432

Fixes:
http://autobuild.buildroot.net/results/719/719a441421030b79c0aa1bbfb707130f3ac87338

Signed-off-by: Romain Naour <romain.naour@gmail.com>
Cc: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/gdb/gdb.mk

index 606f1f96001b5ea3bee0047ded2c0574e87f45da..ccfed4c5fe77c3698971251082ffacf99223acf8 100644 (file)
@@ -67,13 +67,6 @@ GDB_DISABLE_BINUTILS_CONF_OPTS = \
        --disable-ld \
        --disable-gas
 
-# Starting with gdb 7.11, the bundled gnulib tries to use
-# rpl_gettimeofday (gettimeofday replacement) due to the code being
-# unable to determine if the replacement function should be used or
-# not when cross-compiling with uClibc or musl as C libraries. So use
-# gl_cv_func_gettimeofday_clobber=no to not use rpl_gettimeofday,
-# assuming musl and uClibc have a properly working gettimeofday
-# implementation.
 GDB_CONF_ENV = \
        ac_cv_type_uintptr_t=yes \
        gt_cv_func_gettext_libintl=yes \
@@ -83,8 +76,18 @@ GDB_CONF_ENV = \
        bash_cv_must_reinstall_sighandlers=no \
        bash_cv_func_sigsetjmp=present \
        bash_cv_have_mbstate_t=yes \
-       gdb_cv_func_sigsetjmp=yes \
-       gl_cv_func_gettimeofday_clobber=no
+       gdb_cv_func_sigsetjmp=yes
+
+# Starting with gdb 7.11, the bundled gnulib tries to use
+# rpl_gettimeofday (gettimeofday replacement) due to the code being
+# unable to determine if the replacement function should be used or
+# not when cross-compiling with uClibc or musl as C libraries. So use
+# gl_cv_func_gettimeofday_clobber=no to not use rpl_gettimeofday,
+# assuming musl and uClibc have a properly working gettimeofday
+# implementation. It needs to be passed to GDB_MAKE_ENV and not
+# GDB_CONF_ENV, because otherwise it does not get passed to the
+# configure script of nested packages.
+GDB_MAKE_ENV = gl_cv_func_gettimeofday_clobber=no
 
 # The shared only build is not supported by gdb, so enable static build for
 # build-in libraries with --enable-static.