package/cunit: new package
authorMatt Weber <matthew.weber@rockwellcollins.com>
Thu, 1 Nov 2018 18:58:15 +0000 (13:58 -0500)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Thu, 29 Nov 2018 21:39:00 +0000 (22:39 +0100)
Signed-off-by: Matthew Weber <matthew.weber@rockwellcollins.com>
[Thomas: fix license, it's LGPL-2.0+.]
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
DEVELOPERS
package/Config.in
package/cunit/Config.in [new file with mode: 0644]
package/cunit/cunit.hash [new file with mode: 0644]
package/cunit/cunit.mk [new file with mode: 0644]

index 455f2e2b9d50457c1697c267daefd0342092c350..3f51e444215f8e883ba5b606541a3fadcc3604ea 100644 (file)
@@ -1372,6 +1372,7 @@ F:        package/checkpolicy/
 F:     package/checksec/
 F:     package/cgroupfs-mount/
 F:     package/crda/
+F:     package/cunit/
 F:     package/devmem2/
 F:     package/dnsmasq/
 F:     package/dosfstools/
index 38c2654c695bc8734dd3715a362e0de7fd6aee5a..2a1d025d584728c67bb38d4ccd7842b07d873a69 100644 (file)
@@ -142,6 +142,7 @@ menu "Development tools"
        source "package/check/Config.in"
        source "package/cmake/Config.in"
        source "package/cppunit/Config.in"
+       source "package/cunit/Config.in"
        source "package/cvs/Config.in"
        source "package/cxxtest/Config.in"
        source "package/diffutils/Config.in"
diff --git a/package/cunit/Config.in b/package/cunit/Config.in
new file mode 100644 (file)
index 0000000..8bcfa2a
--- /dev/null
@@ -0,0 +1,6 @@
+config BR2_PACKAGE_CUNIT
+       bool "cunit"
+       help
+         An automated testing framework in 'C'.
+
+         http://cunit.sourceforge.net/
diff --git a/package/cunit/cunit.hash b/package/cunit/cunit.hash
new file mode 100644 (file)
index 0000000..bbd43a7
--- /dev/null
@@ -0,0 +1,3 @@
+# Locally calculated:
+sha256 f5b29137f845bb08b77ec60584fdb728b4e58f1023e6f249a464efa49a40f214  CUnit-2.1-3.tar.bz2
+sha256 5d9d73d41a57dd2f34487ef3978a2c13cdb97294baeeb81fcd274796399eb15f  COPYING
diff --git a/package/cunit/cunit.mk b/package/cunit/cunit.mk
new file mode 100644 (file)
index 0000000..9fc3b96
--- /dev/null
@@ -0,0 +1,17 @@
+################################################################################
+#
+# cunit
+#
+################################################################################
+
+CUNIT_VERSION = 2.1-3
+CUNIT_SITE = http://downloads.sourceforge.net/project/cunit/CUnit/$(CUNIT_VERSION)
+CUNIT_SOURCE = CUnit-$(CUNIT_VERSION).tar.bz2
+CUNIT_INSTALL_STAGING = YES
+CUNIT_LICENSE = LGPL-2.0+
+CUNIT_LICENSE_FILES = COPYING
+
+# The source archive does not have the autoconf/automake material generated.
+CUNIT_AUTORECONF = YES
+
+$(eval $(autotools-package))