package/sofia-sip: correct passing of '--enable-ndebug'
authorThomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Tue, 1 Jun 2021 14:34:16 +0000 (16:34 +0200)
committerYann E. MORIN <yann.morin.1998@free.fr>
Tue, 1 Jun 2021 20:40:01 +0000 (22:40 +0200)
The preprocessor option NDEBUG, triggered by the configure option
'--enable-ndebug', should be read as 'no-debug'. When NDEBUG is set, asserts
are _disabled_.

The sofia-sip package had inverted logic, and set '--enable-ndebug' when
BR2_ENABLE_DEBUG was enabled, while it should be the other way around.

Reported-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas De Schampheleire <thomas.de_schampheleire@nokia.com>
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
package/sofia-sip/sofia-sip.mk

index 5c383400ff8352ce3c24fe0c3ff1533ac15b386b..274c72fce8a1e3331aa12e76ed52c118d2e2af63 100644 (file)
@@ -30,7 +30,7 @@ SOFIA_SIP_CONF_OPTS += \
        --without-openssl
 endif
 
-ifeq ($(BR2_ENABLE_DEBUG),y)
+ifeq ($(BR2_ENABLE_DEBUG),)
 SOFIA_SIP_CONF_OPTS += --enable-ndebug
 endif