python-humanize: new package
authorYegor Yefremov <yegorslists@googlemail.com>
Wed, 6 Jul 2016 07:18:16 +0000 (09:18 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Wed, 6 Jul 2016 21:00:57 +0000 (23:00 +0200)
Signed-off-by: Yegor Yefremov <yegorslists@googlemail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/Config.in
package/python-humanize/Config.in [new file with mode: 0644]
package/python-humanize/python-humanize.hash [new file with mode: 0644]
package/python-humanize/python-humanize.mk [new file with mode: 0644]

index 299ca84ee75e193eafce59c0ce32ff36c34301b1..0614cb9ff7e2e8970845ccf6b9be1579a0c5908d 100644 (file)
@@ -665,6 +665,7 @@ menu "External python modules"
        source "package/python-gobject/Config.in"
        source "package/python-html5lib/Config.in"
        source "package/python-httplib2/Config.in"
+       source "package/python-humanize/Config.in"
        source "package/python-id3/Config.in"
        source "package/python-idna/Config.in"
        source "package/python-iniparse/Config.in"
diff --git a/package/python-humanize/Config.in b/package/python-humanize/Config.in
new file mode 100644 (file)
index 0000000..f4f4e67
--- /dev/null
@@ -0,0 +1,9 @@
+config BR2_PACKAGE_PYTHON_HUMANIZE
+       bool "python-humanize"
+       help
+         Python humanize package contains various common humanization
+         utilities, like turning a number into a fuzzy human readable
+         duration ('3 minutes ago') or into a human readable size or
+         throughput.
+
+         http://github.com/jmoiron/humanize
diff --git a/package/python-humanize/python-humanize.hash b/package/python-humanize/python-humanize.hash
new file mode 100644 (file)
index 0000000..bb66e44
--- /dev/null
@@ -0,0 +1,3 @@
+# md5 from https://pypi.python.org/pypi/humanize/json, sha256 locally computed
+md5    e8473d9dc1b220911cac2edd53b1d973  humanize-0.5.1.tar.gz
+sha256 a43f57115831ac7c70de098e6ac46ac13be00d69abbf60bdcac251344785bb19  humanize-0.5.1.tar.gz
diff --git a/package/python-humanize/python-humanize.mk b/package/python-humanize/python-humanize.mk
new file mode 100644 (file)
index 0000000..60ec82b
--- /dev/null
@@ -0,0 +1,14 @@
+################################################################################
+#
+# python-humanize
+#
+################################################################################
+
+PYTHON_HUMANIZE_VERSION = 0.5.1
+PYTHON_HUMANIZE_SOURCE = humanize-$(PYTHON_HUMANIZE_VERSION).tar.gz
+PYTHON_HUMANIZE_SITE = https://pypi.python.org/packages/8c/e0/e512e4ac6d091fc990bbe13f9e0378f34cf6eecd1c6c268c9e598dcf5bb9
+PYTHON_HUMANIZE_SETUP_TYPE = setuptools
+PYTHON_HUMANIZE_LICENSE = MIT
+PYTHON_HUMANIZE_LICENSE_FILES = LICENCE
+
+$(eval $(python-package))