leveldb: disable parallel build
authorFabrice Fontaine <fontaine.fabrice@gmail.com>
Tue, 29 Jan 2019 19:39:29 +0000 (20:39 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Wed, 30 Jan 2019 07:38:47 +0000 (08:38 +0100)
Commit abba4e701246f69bc22ca9045e9932abfe9228e9 did not succeed in
fixing all parallel build failures because sometimes $(SHARED_OUTDIR) is
created but not $(SHARED_OUTDIR)/db so instead of fixing this mess,
revert the patch and disable parallel build as upstream switched to
cmake

Fixes:
 - http://autobuild.buildroot.org/results/9c33692aa130a20b0f8e868156e49990e862d6ee

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/leveldb/leveldb.mk

index 54942a0f275f9db5f616f6a425863a5bab2fd11a..af9e8798282e221cac7a96dd395ce03deeb47fb0 100644 (file)
@@ -17,18 +17,18 @@ LEVELDB_MAKE_ARGS += SHARED_LIBS= SHARED_PROGRAMS=
 endif
 
 define LEVELDB_BUILD_CMDS
-       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE) \
+       $(TARGET_MAKE_ENV) $(TARGET_CONFIGURE_OPTS) $(MAKE1) \
                $(LEVELDB_MAKE_ARGS) -C $(@D)
 endef
 
 define LEVELDB_INSTALL_STAGING_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) \
+       $(TARGET_MAKE_ENV) $(MAKE1) \
                INSTALL_ROOT=$(STAGING_DIR) INSTALL_PREFIX=/usr \
                $(LEVELDB_MAKE_ARGS) -C $(@D) install
 endef
 
 define LEVELDB_INSTALL_TARGET_CMDS
-       $(TARGET_MAKE_ENV) $(MAKE) \
+       $(TARGET_MAKE_ENV) $(MAKE1) \
                INSTALL_ROOT=$(TARGET_DIR) INSTALL_PREFIX=/usr \
                $(LEVELDB_MAKE_ARGS) -C $(@D) install
 endef