package/refpolicy: fix the configure, build and install steps
authorAntoine Tenart <antoine.tenart@bootlin.com>
Fri, 31 Jul 2020 10:10:39 +0000 (12:10 +0200)
committerThomas Petazzoni <thomas.petazzoni@bootlin.com>
Fri, 4 Sep 2020 09:55:02 +0000 (11:55 +0200)
The refpolicy configure and build step were not correctly defined. The
configuration was split between the configure and build step, while
both the compilation and the installation were done in the install
step. Fix this by moving all the configuration within the
configuration step and by adding a call to make in the build step to
compile the policy.

Signed-off-by: Antoine Tenart <antoine.tenart@bootlin.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
package/refpolicy/refpolicy.mk

index dc038001bd1db65dd7ca97b8516c600524664a69..edfbb3542c38d68d87f60d8c64db04144e4fb7d3 100644 (file)
@@ -105,12 +105,13 @@ define REFPOLICY_CONFIGURE_CMDS
        $(SED) "/MONOLITHIC/c\MONOLITHIC = y" $(@D)/build.conf
        $(SED) "/NAME/c\NAME = targeted" $(@D)/build.conf
        $(REFPOLICY_CONFIGURE_SYSTEMD)
+       $(REFPOLICY_COPY_EXTRA_MODULES)
+       $(REFPOLICY_MAKE) -C $(@D) bare conf
+       $(REFPOLICY_CONFIGURE_MODULES)
 endef
 
 define REFPOLICY_BUILD_CMDS
-       $(REFPOLICY_COPY_EXTRA_MODULES)
-       $(REFPOLICY_MAKE) -C $(@D) DESTDIR=$(STAGING_DIR) bare conf
-       $(REFPOLICY_CONFIGURE_MODULES)
+       $(REFPOLICY_MAKE) -C $(@D) policy
 endef
 
 define REFPOLICY_INSTALL_STAGING_CMDS