xbmc: Add option for Goom screensaver
authorBernd Kuhls <bernd.kuhls@t-online.de>
Fri, 1 Aug 2014 17:32:38 +0000 (19:32 +0200)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Sun, 3 Aug 2014 08:41:36 +0000 (10:41 +0200)
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/xbmc/Config.in
package/xbmc/xbmc.mk

index 04bc86f6f2fdf64a0670248f9c3fb41b6d59bdcb..6a00531e796206ba5e5feb0ca11cb7dc3fdf92c8 100644 (file)
@@ -128,6 +128,15 @@ config BR2_PACKAGE_XBMC_LIBBLURAY
 comment "libbluray support needs a toolchain w/ dynamic library"
        depends on BR2_PREFER_STATIC_LIB
 
+config BR2_PACKAGE_XBMC_GOOM
+       bool "goom screensaver"
+       depends on BR2_PACKAGE_XBMC_GL
+       help
+         Enable goom screensaver
+
+comment "goom needs an OpenGL backend"
+       depends on !BR2_PACKAGE_XBMC_GL
+
 config BR2_PACKAGE_XBMC_LIBCEC
        bool "hdmi cec"
        depends on !BR2_PREFER_STATIC_LIB # libcec
index c868b59045c89fa7ac0057e79b7a711891827b2f..920d7315b69ff04b3d907085b75c9800623550b9 100644 (file)
@@ -109,6 +109,12 @@ XBMC_CONF_OPT += --disable-gles
 endif
 endif
 
+ifeq ($(BR2_PACKAGE_XBMC_GOOM),y)
+XBMC_CONF_OPT += --enable-goom
+else
+XBMC_CONF_OPT += --disable-goom
+endif
+
 ifeq ($(BR2_PACKAGE_XBMC_LIBUSB),y)
 XBMC_DEPENDENCIES += libusb-compat
 XBMC_CONF_OPT += --enable-libusb