openblas: disable OpenMP
authorArnout Vandecappelle <arnout@mind.be>
Sun, 20 Nov 2016 16:04:41 +0000 (17:04 +0100)
committerThomas Petazzoni <thomas.petazzoni@free-electrons.com>
Mon, 21 Nov 2016 20:44:58 +0000 (21:44 +0100)
For powerpc (and powerpc only), the openblas build system will enable
USE_OPENMP when threads are enabled. But the toolchain wasn't
necessarily built with OpenMP support. So explicitly disable OpenMP -
for all architectures, not just powerpc, just to keep things simple.

We could have autodetected whether OpenMP is available at configure
time, but that would be more of a feature patch, it's up to upstream
to do that.

Fixes:
http://autobuild.buildroot.net/results/423b5e79cd4342d6c160ed478054b294b0826c6a
http://autobuild.buildroot.net/results/c9e554c8f880b49b3c9203725ac5e6565b7e5c6f

Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
package/openblas/openblas.mk

index 9583e0ea2978f6b61b7295434a6766bc0ae8b10c..a26e10a43ce601da56dde7bf584b20aa6c9518c8 100644 (file)
@@ -31,6 +31,9 @@ else
 OPENBLAS_MAKE_OPTS += USE_THREAD=0
 endif
 
+# We don't know if OpenMP is available or not, so disable
+OPENBLAS_MAKE_OPTS += USE_OPENMP=0
+
 # Static-only/Shared-only toggle
 ifeq ($(BR2_STATIC_LIBS),y)
 OPENBLAS_MAKE_OPTS += NO_SHARED=1