libupnpp: fix libupnp detection with static linking
authorPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Feb 2015 15:43:46 +0000 (16:43 +0100)
committerPeter Korsgaard <peter@korsgaard.com>
Fri, 27 Feb 2015 15:43:46 +0000 (16:43 +0100)
Fixes http://autobuild.buildroot.net/results/566/566e1510f94670d4ff642c7bfa9918c1d9ec583f/

Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
package/libupnpp/libupnpp.mk

index ad790f85ac0892d147cb8f83fa6d2391548b7a46..853a7244ea3420f2398ab3083f3389ec5489f70a 100644 (file)
@@ -11,4 +11,10 @@ LIBUPNPP_LICENSE_FILES = COPYING
 LIBUPNPP_INSTALL_STAGING = YES
 LIBUPNPP_DEPENDENCIES = expat libcurl libupnp
 
+# configure script fails to link against the dependencies of libupnp
+# causing upnp detection to fail when statically linking
+ifeq ($(BR2_STATIC_LIBS),y)
+LIBUPNPP_CONF_ENV += LIBS='-lthreadutil -lixml -pthread'
+endif
+
 $(eval $(autotools-package))